SOLVED After windows 10 update search in outlook 2013 never complets

Joined
Dec 9, 2015
Messages
36
Reaction score
7
A few days ago Microsoft forced a major Windows 10 features update on my computer and some things now do not work as they did before. I noticed that when I tried to do a search for anything on some outlook mail boxes it would never finish. On some mail boxes it seems to work, with "current Mailbox" and "Subfolders" while on others it does not. Where it worked before on "All Outlook Items" nothing now ever completes.

I tried working with Microsoft support and their fix was to reload Office 2013 which did not change anything. I rebuilt the Index for Microsoft Search and made sure the Outlook folder was included and am still having issues.

Advice would be greatly appreciated!
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,612
Reaction score
1,140
Hi dac8190,

Did Microsoft guy get you to go check your ost and pst files are actually set to be allowed to be indexed in the first place? If not, then no search will complete.

You can confirm where files are saved via File > Account settings > Data Files [tab]

Now just select an outlook file and click open file location then:
  • Right click on the .pst or .ost file and click Properties
  • Click Advanced
  • Make sure that the box next to Allow this file to have contents indexed in addition to file is checked.
  • Click OK

It may not be your problem, but it would be worth checking all the same.
 
Joined
Dec 9, 2015
Messages
36
Reaction score
7
Wow, rebuilding the index sure takes a long time! I'm assuming that the index is the same for all Microsoft searches (File Explorer, Outlook and any other Microsoft application that supports searching). I'm beginning to think that during the last update my Indexing Options were turned off or something and by forcing and reconfiguring everything it seems to be better, although different than it was before the update.

My OS on my desktop is:

Windows 10 Pro (when working on the Cortana issue I upgraded to Pro)
Version 1703
KB4022725 (OS Build 15063.413)

It seems that this is the "Creator" OS and is the one on my Desktop where as my Laptop has:

Windows 10 Home
Version 1607
KB4022725 (OS Build 15063.413 and 15063.414)

I'm not sure what I've done to deserve the "Creator" version, unless it is the one "Windows 10 Pro" needs which I assume is a version for very advanced users and I have yet to find how that is managed and why. Another mystery to solve at some point!

Back to Outlook.

I have my disk (the "F" drive) with all of my user data (including the Outlook PST files that I routinely use set to allow content indexed:
upload_2017-6-24_10-13-51.png


I have tried to set the PST files on my "F" disk to support content indexing and when I do it an go back a look it is set, but at some point that configuration changes to not set:

upload_2017-6-24_10-17-0.png


Outlook claims that everything is indexed:

upload_2017-6-24_10-20-4.png


It takes almost 48 hours to rebuild the Index:
upload_2017-6-24_10-27-26.png


And every time I do a rebuild I get an different number of "items indexed", sometimes more sometimes less. I wonder why the inconsistencies?

After the rebuild when doing Outlook searches with different "Scope" on a PST file sometimes it completes and might even be accurate, as before the rebuild it didn't find anything. When I select "All Outlook Items" I now get a return that again might even be accurate but the indication is that it never completes the search.

I have 3 active e-mail accounts that I use:

upload_2017-6-24_10-44-51.png



And several Archive PSTs:

upload_2017-6-24_10-48-13.png


I assume that if I add one of my "Archived" PST files from a drive not being indexed it will not be searched unless I force that PST file to be indexed and then re-index everything?

Thanks for your help and advice!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top