SOLVED DHCP won't start : Error 5


Joined
Oct 2, 2016
Messages
2
Reaction score
0
Have not been able to get automatic IP on LAN because DHCP won't start .
The error message when trying to restart DHCP is :
"Windows was unable to restart DHCP Client service . Error 5 : Access Denied."
I am able to connect to the internet with a static IP .
I have no restoration points on my computer .

My specs :
OS : Windows 10 Pro 64-bit version 1511
CPU : AMD FX-6100
RAM : DDR3 12 Gigabytes
Motherboard : Gigabyte GA-990FXA-UD5 (Socket M2)
Graphics : AMD Radeon HD 6700
Ethernet : Realtek PCIe GBE Family

This is what I have tried so far -->

The usual commands :
  • ipconfig /flushdns
  • netsh int ip reset c:\resetlog.txt
  • netsh winsock reset catalog
  • netsh int tcp set heuristics disabled
  • netsh int tcp set global autotuninglevel=disabled
  • netsh int tcp set global rss=enabled
  • ipconfig / release
  • ipconfig /renew

I have , of course , contacted my ISP and they have found nothing wrong on their side (or in the router) .

I have also uninstalled / reinstalled my network adaptor .

Have also tried modifying the registry by assigning permissions at :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DHCP\

Now digging deeper , I set the command :
CMD /K SC QC DHCP

This was what I got (note the system is in Spanish) :
TIPO_INICIO : 2 AUTO_START
CONTROL_ERROR : 1 NORMAL
NOMBRE_RUTA_BINARIO : C:\Windows\system32\svchlst.exe -k LocalServiceNetworkRestricted
GRUPO_ORDEN_CARGA : TDI
ETIQUETA : 0
NOMBRE_MOSTRAR : Cliente DHCP
DEPENDENCIAS : MSI
TDX
AFD
NOMBRE_INICIO_SERVICIO : NT Authority\LocalService

Any ideas? ,
Thanks .
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
Hi agmz30,

Welcome to the Forum.

It appears your Network Service account may not have sufficient permissions to access the Registry in regards to the DHCP service.

Something you can do that may resolve this for you is the following:
  • Press Windows key and R key together to open the Run dialog
  • In the Run dialog type regedit then click OK
  • When the User Account Control appears click Yes
  • The Registry Editor window will now open.
    • On the left pane click and expand to the following location:
HKEY_LOCAL_MACHINE
— SYSTEM
— CurrentControlSet
— Services
Dhcp
  • Right-click on the Dhcp key In the left pane and select Permissions

    Sample image

    permissions.png
  • In the window that opens click the Add button

    Sample image

    permissions2.png

  • In the next window that opens type network service in the empty field then click Check Names button.

    This will open the window again showing NETWORK SERVICE in the field. Click OK

    Sample images

    permissions3.png

  • This will return you to the Permissions for Dhcp window. Check the Full Control box under the Allow column, then click OK

    Sample image

    permissions4.png

  • You will now be back at the Registry Editor window. Click once on the Dhcp key in left pane, then type tc to auto scroll down to the Tcpip key.

    Alternatively, just scroll down to this key.
HKEY_LOCAL_MACHINE
— SYSTEM
— CurrentControlSet
— Services
Tcpip​
  • When you get there, right-click on the Tcpip key in the left pane and select Permissions
  • In the window that opens click the Add button
  • In the window that opens as before type network service in the empty field and click Check Names
  • When you see this window showing NETWORK SERVICE click OK
  • Check the Full Control box under Allow column then click OK
  • Close the Registry Editor, and any other open programs.
  • Restart computer for changes to take affect.

Once you have done this and restarted computer, hopefully this DHCP error 5 will not bother you again.

Regards,

Regedit32
 
Joined
May 6, 2015
Messages
2,846
Reaction score
500
I would have just assigned my machine a static IP just outside the routers DHCP range and made sure everything else in networking was ok before doing that. But then I remember the days of Hosts files copied on floppies via 'sneakernet' and Trumpet Winsock!
 
Joined
Jul 31, 2018
Messages
1
Reaction score
0
Hi
Ethernet doesn't have a valid IP configuration

So I want to "Restart or Stope" the DHCP Client; But

Windows cannot stop the DHCP client service on local computer.
error 5: access is denied.
and I have done whatever you learned!
 
Joined
Oct 26, 2016
Messages
2,328
Reaction score
690
My specs :
OS : Windows 10 Pro 64-bit version 1511
CPU : AMD FX-6100
RAM : DDR3 12 Gigabytes
Motherboard : Gigabyte GA-990FXA-UD5 (Socket M2)
Graphics : AMD Radeon HD 6700
Ethernet : Realtek PCIe GBE Family

Version 1511?? Just FYI: this version is not supported by Microsoft anymore (since October 2017 and the final update was April 10 2018).
I am surprised that your system is not complaining to get updated (Feature update April 2018)....
 
Ad

Advertisements

Joined
Sep 26, 2017
Messages
3,042
Reaction score
588
agmz30 said:
My specs :
OS : Windows 10 Pro 64-bit version 1511

Hold down the the Windows key and press R, type winver and you will see the numbers needed when posting a problem or asked for more information. The Version number is made up of the year and month of release, e.g. Version 1803 means 2018 and March. Your 1511 was 2015 and November, quite old in computing terms. The actual release may be delayed at times. The Build number is the update to the Version and will increase over time.
 
Joined
Nov 19, 2013
Messages
6,216
Reaction score
1,260
Version 1511?? Just FYI: this version is not supported by Microsoft anymore (since October 2017 and the final update was April 10 2018).
I am surprised that your system is not complaining to get updated (Feature update April 2018)....
Not altogether!
The post was in 2016
 
Joined
Dec 9, 2019
Messages
3
Reaction score
0
Have not been able to get automatic IP on LAN because DHCP won't start .
The error message when trying to restart DHCP is :
"Windows was unable to restart DHCP Client service . Error 5 : Access Denied."
I am able to connect to the internet with a static IP .
I have no restoration points on my computer .

My specs :

OS : Windows 10 Pro 64-bit version 1511
CPU : AMD FX-6100
RAM : DDR3 12 Gigabytes
Motherboard : Gigabyte GA-990FXA-UD5 (Socket M2)
Graphics : AMD Radeon HD 6700
Ethernet : Realtek PCIe GBE Family

This is what I have tried so far -->

The usual commands :
  • ipconfig /flushdns
  • netsh int ip reset c:\resetlog.txt
  • netsh winsock reset catalog
  • netsh int tcp set heuristics disabled
  • netsh int tcp set global autotuninglevel=disabled
  • netsh int tcp set global rss=enabled
  • ipconfig / release
  • ipconfig /renew

I have , of course , contacted my ISP and they have found nothing wrong on their side (or in the router) .

I have also uninstalled / reinstalled my network adaptor .

Have also tried modifying the registry by assigning permissions at :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DHCP\

Now digging deeper , I set the command :
CMD /K SC QC DHCP

This was what I got (note the system is in Spanish) :
TIPO_INICIO : 2 AUTO_START
CONTROL_ERROR : 1 NORMAL
NOMBRE_RUTA_BINARIO : C:\Windows\system32\svchlst.exe -k LocalServiceNetworkRestricted
GRUPO_ORDEN_CARGA : TDI
ETIQUETA : 0
NOMBRE_MOSTRAR : Cliente DHCP
DEPENDENCIAS : MSI
TDX
AFD
NOMBRE_INICIO_SERVICIO : NT Authority\LocalService

Any ideas? ,
Thanks .

It works for me on windows 10.
However, I have a follow up question..
Is there a security risks if 'NETWORK SERVICE'
will be granted a full permission ?
 
Ad

Advertisements

Joined
Dec 9, 2019
Messages
3
Reaction score
0
Hi agmz30,

Welcome to the Forum.

It appears your Network Service account may not have sufficient permissions to access the Registry in regards to the DHCP service.

Something you can do that may resolve this for you is the following:
  • Press Windows key and R key together to open the Run dialog
  • In the Run dialog type regedit then click OK
  • When the User Account Control appears click Yes
  • The Registry Editorwindow will now open.
    • On the left pane click and expand to the following location:
HKEY_LOCAL_MACHINE​
— SYSTEM​
— CurrentControlSet​
— Services​
Dhcp​






  • Right-click on the Dhcp key In the left pane and select Permissions

    Sample image

    View attachment 4090


  • In the next window that opens type network service in the empty field then click Check Names button.

    This will open the window again showing NETWORK SERVICE in the field. Click OK

    Sample images

    View attachment 4092

  • This will return you to the Permissions for Dhcp window. Check the Full Control box under the Allow column, then click OK

    Sample image

    View attachment 4093

  • You will now be back at the Registry Editor window. Click once on the Dhcp key in left pane, then type tc to auto scroll down to the Tcpip key.

    Alternatively, just scroll down to this key.
HKEY_LOCAL_MACHINE​
— SYSTEM​
— CurrentControlSet​
— Services​
Tcpip​





  • When you get there, right-click on the Tcpip key in the left pane and select Permissions
  • In the window that opens click the Add button
  • In the window that opens as before type network service in the empty field and click Check Names
  • When you see this window showing NETWORK SERVICE click OK
  • Check the Full Control box under Allow column then click OK
  • Close the Registry Editor, and any other open programs.
  • Restart computer for changes to take affect.

Once you have done this and restarted computer, hopefully this DHCP error 5 will not bother you again.

Regards,

Regedit32

It works for me on windows 10.
However, I have a follow up question..
Is there a security risks if 'NETWORK SERVICE'
will be granted a full permission ?
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
6,216
Reaction score
1,260
Loise. Better to open a new thread with your query. This one is over three years old, and has been marked as solved. - Many things have changed.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top