Edge browsing SLOWED way down


Joined
Dec 26, 2015
Messages
166
Reaction score
14
All current updates winH20,
Speed test shows over 650 Mbps
router/modem reboot

Open to suggestions
thanks
 
Ad

Advertisements

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
13,177
Reaction score
2,255
Same here.
Not sure what's going on.
Thought it might be an extension that I had added on, but after removing them it hasn't seemed to have improved.

Now I'm thinking that all things internet, might be impacted by the recent discovery of a galactic hack of multiple government agencies as well as many private sector business.
Pretty sure there is a lot of investigative diagnostics taking place in real time as well as traffic filtering so that everything gets a careful look.

When giants like Solar Winds and Fire Eye get hacked people are likely to be walking on egg shells for a while
 
Joined
Jun 24, 2015
Messages
300
Reaction score
90
I just switched to the new Chromium Edge browser and it's fast and the only extension I'm using is Ublock Origin and if it's slower now then it used to be before 20H2 update it must really be fast.
 
Joined
Dec 26, 2015
Messages
166
Reaction score
14
Not much update but still the same today. Haven't had chance to check with xfinity and see what they say.
 
Ad

Advertisements

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
13,177
Reaction score
2,255
Yep.
I even went so far as to test drive their latest Beta version of Edge and it's the same.
Not saying it's remarkably slower, just noticeably so.
 
Ad

Advertisements

Joined
Jun 24, 2015
Messages
300
Reaction score
90
I have Firefox 84 installed and haven't noticed any changes seems to work as good as it always has.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top