Mail App


Joined
Jun 14, 2018
Messages
2
Reaction score
1
I use the Windows 10 mail app for my emails. It works fine until I try to click on a link. At this point, I get the message pop of on "Unable to open [link adress]". I have looked at other people who have had this problem and the solution was that their Windows Firewall was deactivated, mine is not. It seems that not many people have had this problem and if they did it was resolved by activating their Windows Firewall, as I stated before; since this is not the root of my problem, if you have any other solutions I'd be happy to try them out.
 
Joined
Jun 14, 2018
Messages
2
Reaction score
1
I figured out what it was. I did not have a default browser set up, therefore, the Mail App couldn't open the links. For anyone that is having this same problem, you can go to your settings, then click systems, and search for choose default web browser, and select yours of choice.
 
Ad

Advertisements

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
11,961
Reaction score
1,895
Good find.
Thanks for coming back and reporting your solution.
Much appreciated.
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
4,186
Reaction score
805
I am curious. For the help for other readers, could you give a more detailed run through of your actions?
I don't think there is a "choose your default browser" in settings .- System. It would be under "Apps"

Had you , by some means, uninstalled both Edge and IE? Otherwise, on startup, windows 10 would have accepted, as priority, Edge, or, failing that, IE. I could be mistaken, but I don't think it possible that it could ignore both.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top