Slow Page Loading Of Browsers

Discussion in 'Networking' started by TerryWood, Mar 17, 2017.

  1. TerryWood

    TerryWood

    Joined:
    Mar 17, 2017
    Messages:
    3
    Likes Received:
    0
    Hi @ Win10 forums

    Using Win 64 Bit Chrome, Opera, Edge and IE7 browsers. I have fibre 27gbs download speed 1.6 upload.

    What I am finding is that all my browsers are slow in loading web pages particularly rich content but even light ones are not instantaneous. Examples are shown below. MS Edge is probably the quickest but it is still a crawl to load a page

    http://www.telegraph.co.uk/ 20 Seconds

    http://www.dailymail.co.uk/home/index.html - 30 seconds

    http://www.express.co.uk/ 20 Seconds

    https://www.ft.com/ 15 Seconds to load

    Above measured on Chrome.

    I have searched the web and tried many things but I cannot improve the speed of page loading. Tried new install Firefox, bare install no addons, nothing. Just as bad

    Can anyone give me pointers on resolving this issue I really would be grateful. One final point since aquiring fibre broadband the page loading is no better than ADSL.

    Thank you

    Terry
     
    TerryWood, Mar 17, 2017
    #1
    1. Advertisements

  2. TerryWood

    Trouble Noob Whisperer Moderator

    Joined:
    Nov 19, 2013
    Messages:
    10,139
    Likes Received:
    1,465
    Location:
    Northwest Indiana U.S.A.
    Try switching your DNS Server addresses manually to Google Public DNS and see if that produces any better results.
    https://developers.google.com/speed/public-dns/docs/using
    Use 8.8.8.8 as preferred and 8.8.4.4 as Alternate
    The example under the section labeled "Windows" should help.
    Also double check
    services.msc
    and confirm that DNS client service is running and set to automatic
    THEN
    Open an elevated command prompt and type
    ipconfig /flushdns
    hit enter
    Test in your browsers.
    NOTE: Initially you may not see an immediate improvement until your local cache is replenished after flushing it.
     
    Trouble, Mar 17, 2017
    #2
    1. Advertisements

  3. TerryWood

    TerryWood

    Joined:
    Mar 17, 2017
    Messages:
    3
    Likes Received:
    0
    Hi Trouble
    Noob Whisperer

    Thank you for such a comprehensive reply.

    I had already done nearly all of what you suggested apart from checking services.msc (which is on Automatic Trigger Start) but I have repeated them without success. I was not aware about the lack of immediate improvement until the local cache is replaced. Nonetheless after some hours there is no change. Do you have any other suggestions please. In addition have you come across the level of slow loading before?

    Thank you

    Terry
     
    TerryWood, Mar 18, 2017
    #3
  4. TerryWood

    Trouble Noob Whisperer Moderator

    Joined:
    Nov 19, 2013
    Messages:
    10,139
    Likes Received:
    1,465
    Location:
    Northwest Indiana U.S.A.
    No, I can't say that I have personally, but this forum and elsewhere on the web is loaded with similar complaints.
    Do you now have or have you in the past had any third party security suites installed on your computer?
    Do you have the most recent driver installed for your network adapter?
    Most browser will have, somewhere in their configuration settings, a check box associated with using "hardware acceleration" or not.
    Although using hardware acceleration is generally considered optimal, you might want to experiment with toggling that off and on.
     
    Trouble, Mar 18, 2017
    #4
  5. TerryWood

    TerryWood

    Joined:
    Mar 17, 2017
    Messages:
    3
    Likes Received:
    0
    Hi Trouble

    Thanks for your reply

    1) Security Suites

    Qihoo Total Security Essentials - Removed
    Avira Antivirus Free - Removed
    BitDefender Free = Current Antivirus
    ZoneAlarm Free Firewall - Removed
    TinyWall Free - Removed
    Evorim FireWall - Removed
    Private Firewall = Current Antivirus

    MalwareBytes Anti - Exploit

    Some on demand security
    MalwareBytes AntiMalware Free
    Hitman Pro Free

    In all cases of removal I have rigorously cleaned out program remnants.
    I have tried running current Antivirus (BitDefender) disabled. It has made no difference.

    2) Network Driver

    I use Iobit Driver Update. The last update was 23 12 2016 For Realtek PCIe GBE Family Controller v 10.13.1223.2016

    3) Browser Hardware Acceleration

    I had already tried that, no joy. On your mention I tried it again. I cannot observe any noticeable difference.

    So any other suggestions, I am really struggling.

    Thanks

    Terry
     
    TerryWood, Mar 18, 2017
    #5
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. Lakna Ariyathilaka

    All browsers are slow after windows 10 upgrade

    Lakna Ariyathilaka, Jul 30, 2015, in forum: Windows 10 Support
    Replies:
    16
    Views:
    84,600
  2. lluinenburg
    Replies:
    55
    Views:
    191,311
  3. Anouk

    Internet browsers problem with windows 10

    Anouk, Aug 1, 2015, in forum: Windows 10 Support
    Replies:
    5
    Views:
    1,690
    Anouk
    Aug 1, 2015
  4. Vicki

    Can't Read this Page and Slow Etsy on-line store

    Vicki, Aug 3, 2015, in forum: Installation, Setup and Updates
    Replies:
    3
    Views:
    858
    Vicki
    Aug 4, 2015
  5. Geo
    Replies:
    1
    Views:
    5,000
    moggy
    Aug 13, 2015
  6. Michael
    Replies:
    2
    Views:
    585
    Michael
    Aug 28, 2015
  7. Bob Bobberson
    Replies:
    5
    Views:
    1,628
    Bob Bobberson
    Mar 2, 2016
  8. windy10

    Browser loading slow - Windows or Browser at fault

    windy10, Jul 12, 2016, in forum: General Discussion
    Replies:
    7
    Views:
    621
    Norton
    Jul 13, 2016
Loading...