USB Drive wont show Names

Joined
Sep 28, 2016
Messages
10
Reaction score
0
Thumb Drives i insert only shows drive letters? anyone experience this? i did reformat them and i believe my system is clean, i can eject them without problem. im using win 10 pro updated, and bitdefender 2017 total protection as my fw and AV.
 
Last edited:
A

Advertising

Joined
May 6, 2015
Messages
2,352
Reaction score
361
When you formatted them did you give them a name? There is a field in the format command and it works for me.
 
A

Advertising

Joined
Feb 18, 2016
Messages
2,826
Reaction score
621
Pulinador If you didn't do as Tim suggested. You should be able to right click and rename the USB drives.
 
Joined
Sep 28, 2016
Messages
10
Reaction score
0
yes. i gave them a name.. tried renaming.. still i will show only drive letters.
 
Joined
May 6, 2015
Messages
2,352
Reaction score
361
Pulinador If you didn't do as Tim suggested. You should be able to right click and rename the USB drives.
Renaming like that renames the drive in File explorer. Renaming the actual thumb drive or SDHC card while formatting renames the volume on the card/thumb drive.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
2,937
Reaction score
908
So what happens if you use an old windows 7 tweak:
  • close file explorer
  • right-click on Start
  • left-click on Command prompt
  • at the prompt type or copy & paste the following:

    Code:
    reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer" /v ShowDriveLettersFirst /t reg_dword /d 00000004
    Press Enter key

  • Close Command Prompt
  • Reopen File Explorer
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
2,937
Reaction score
908
If the above does not work then check the sharing tab in properties of thumb drive
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
2,937
Reaction score
908
If the tweak fails and sharing is fine on thumb drive, then only other thing I can think of is you have some ancient relic for a thumb drive that still has a hidden autorun.inf which will need editing to prevent it auto loading drive every time.

That though is highly unlikely but you could check via file explorer and folder options to show hidden files and make sure 'hide protected operating system files' is not checked.
 
Joined
Sep 28, 2016
Messages
10
Reaction score
0
didnt work.. i can see the drive. it has a letter. can use it normally copy, transfer files. its just the name that wont appear.

uninstall / reinstalled drivers
did the add registry

i cant system restore last restore point is august.

 
Joined
Sep 28, 2016
Messages
10
Reaction score
0
yes.. not autorun file. thats what i thought in the first place or some virus doing stuff, i a couple of scans. system is clean. using bitdefender 2017 total security..
 
Joined
Oct 1, 2014
Messages
1,871
Reaction score
261
I agree all you should need to do is select the drive by right click and enter a name.

If nothing else works you might want to try using Diskpart to clean the drive then create a partition and format it.
 
Joined
Sep 28, 2016
Messages
10
Reaction score
0
"I did the steps above: the partition name was correctly changed in the "Disk Management" and reading it via "Command Prompt". But "Windows Explorer" continues showing the partition name as "Local Disk", even after I reboot Windows 10. What can be done to Windows Explorer shows the correct name?
I've found that with the so-called November Upgrade the situation only got worse. External hard drives remain only called "Local drive" in File Explorer, but flash drives have no name at all, just a drive letter." -windows
 
Joined
May 6, 2015
Messages
2,352
Reaction score
361
I when to the view properties of file explorer and turned off show drive letters.
I renamed my i: ( flash card) to idrive.

Found a new flash card, loaded it and showed idrive. Formatted it FAT32 ( default) and gave it a name the name showed up. removed the card and idrive came up again. reinserted the card and its name appeared.
Then I reformatted the card NTFS with a different name and it all worked as above.

I have an external drive, a Seagate, that shows up as External Disk (F: ) Been this way since 10240 through 1500 and now 1607

I am running a plain jane Windows 1607 with the flash card and usb drives from the factory...no fancy stuff at all.

It would not occur to me to use the registry for something like this. ( I do use it every time there is a complete new release to permanently turn off the caps lock key)
 
Joined
Oct 1, 2014
Messages
1,871
Reaction score
261
Something else to try since it only seems to happen with USB drives, it to check the USB Root Hubs in Device Manager. On the properties-Advanced tab there may be a Reset Hub option.

Go up to the Disk Drives section in Device Manager and check the properties for the drive. Is it set to Quick Removal or Better Performance?

I see you have an X99 motherboard. Mine is made by ASUS and looks a little different than yours in the USB area.
 
Joined
Sep 28, 2016
Messages
10
Reaction score
0
computer is clean no virus.. checked all processes as well.. i did reset the hub still the same.. it seems like the computer doesn't show the volume drive name but shows the drive. i can rename the drive even when i eject the flash drive.
 
Joined
Oct 1, 2014
Messages
1,871
Reaction score
261
Even if the drive was unnamed it should still have some type of label, like mine says "USB Drive". So it seems something may be corrupted, perhaps a system file check would find something.

Of course, I don't run your anti-virus.. I suppose there could be some type of quirk with it. Maybe check their website for info.
 
A

Advertising

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top