DRIVER_POWER_STATE_FAILURE 0x9f [ ntoskrnl.exe ] During Installation


Joined
Apr 28, 2016
Messages
4
Reaction score
0
Device Informations:
HP Probook 440 G2 Laptop
Kingston UV400 240GB SSD (Boot Drive)
Seagate 500GB SATA III 5400rpm (Storage Drive, inside the Optical Drive bay)
Kingston HyperX 2x4GB 1600Mhz CL9 RAM
Intel Core i5 4210U
Intel HD4400 Graphics ( There is no dedicated video card )
BIOS Updated to latest version M74 01.42 and configured to Boot using native UEFI.

I have been a Linux user for a long time, but for work reasons I've decided to dual-boot my Laptop with Windows 10 Pro. So, for starters, I formatted both my SSD and HDD, used diskpart to convert my SSD to GPT and created a bootable windows 10 drive, also using GPT (Tried RUFUS and WINUSB ). Note that I've already tried to install it over 10 times with 3 differnt ISOs and all of them gave me the exact same problem.

The problem happens right after the Windows instalaltion, so I didn't even mess up with re-partitioning or installing drivers at all. After Windows installs itself and goes for the first reboot to start configuring itself, it hangs on a black screen and after 10 minutes, the BSOD appears with DRIVER_POWER_STATE_FAILURE. The machine reboots and Windows starts configuring itself and then reboots again, and the BSOD shows up again. The 3 ISOs i've tested contain different Windows 10 versions, one of them already including the Anniversary Update, but all of them give me the exact same issue.

After the 2 BSODs when installing Windows, I let the Windows Update do it's thing until there are no updates available. But even then, when rebooting, sleeping or shutting down, the same error keeps happening.

I've tried to manually update driver by driver by going on Device Manager, clicking one-by-one and searching for updates. Tried going to the HP Probook 440 G2 driver section and installing all drivers. And, at last, I've tried downloading the Driver Booster program, and it updated every single remaining driver on the Laptop but the problem still persists.

Disabling Fast Boot doesn't work. On Linux the machine behaved normally, sleeping, hibernating, restarting and shutting down. Even now, when I boot on a live usb containing ubuntu, it works as it should. The laptop came with Windows 8.1, before I've installed Linux, and it also used to work just fine.

I've tried swapping the RAM modules for the one that came with the laptop, a single 4GB sitck, but the problem persists. Also tried to update the SSD firmware using Kingston's application but there aren't any newer versions available. The sfc /scannow returns no integrity violations.

There problem also happens with or without peripherals attatched to the laptop. I use, mainly, a wireless logitech mouse.

Under Windows Event Viewer, it givers me a bunch of Critical Errors stated as Kernel-Power 41 ( Task 63 ). The Bugcheck code from the DMP is 0x9f, the "culprit" being ntoskrnl.exe. The Parameter 1 is 0x3, which acording to Microsoft's website https://msdn.microsoft.com/en-us/library/ff559329(v=vs.85).aspx means that " A device object has been blocking an IRP for too long a time ".

I've attatched a .dmp file on my dropbox account but I wasn't able to read it completely, I coudn't make WinDBG work at all. I've managed to "read" the .dmp using a program called WhoCrashed, but i'm pretty sure it's lacking information since I can't see the thread which went into deadlock. I'm currently on a fresh install, with no ideas on how to proceed. Would really appreciate some help. Thanks.

Dmp files: https://www.dropbox.com/sh/wcs1otwghgw1n1i/AAACRhB3AlzGAxdWBChSAZaea?dl=0
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top