Acer XC-895 new SSD wont recognise old HDD

May 8, 2018
Reaction score

I am hoping someone can help. Im stuck on what to do next.

Computer: Acer XC-895 Desktop.
SSD: PATRIOT P210S128G25 P210 2.5" 128GB SATA 6Gb/s Solid State Drive
HDD: Western Digital
SSD runs Windows 11, HDD runs Windows 10.


I added a SSD and setup windows on it. I can boot to this SSD, all good.

But the problem is that windows on the SSD will not recognise the old Western Digital HDD. BUT, weirdly, if I boot to the HDD it will recognise the SSD in windows explorer.

I have tried device manager, I have tried changing SATA ports on the motherboard. I have changed SATA cables over to prove both OK.

My aim is to format the HDD and make it a secondary drive for storing files. My next step is to format the HDD, but I cant see how this will make much difference.

Please help?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question