GPO script policies not working on Windows 10 1809


Apr 9, 2019
Reaction score
It seems group policies under Local Group Policy Editor>Computer configuration>Administrative Templates>System>Scripts are not working in Windows 10 version 1809. Back in 1803 they worked perfectly fine.

I can confirm that they can be set and the changes are shown in the registry (Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System) but the system does not care about them and uses default settings.

More importantly i want the "Specify maximum wait time for group policy scripts" to work since it prevents my PC restarting or shutting down unless 600 seconds (aka 10 minutes which is the default value - which is a ridiculously long value and Microsoft should use a more appropriate default value like 5 seconds) of uptime has passed, as this PC is under a domain which is not always accessible as i am not always connected to the domain network.

Back in 1803 i had this policy set to 1 second to prevent this issue. Now none of the policy settings there work anymore.

Anyone found a fix or should i downgrade back to 1803?
Sep 26, 2017
Reaction score
Is it possible the version of Win10 may be important to know, Windows 10 Pro, Enterprise, or Education, for running GPO?


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question