Sleep Mode Problem: Suggested Cure ?


Joined
Dec 4, 2017
Messages
61
Reaction score
2
Hello,

The previous thread on this problem is pretty long, so thought I'd start anew.

Concerning the problem I have, and apparently many others, of my HP Pavililion desktop
not entering sleep mode (fan keeps working) after a recent MS update
Absolutely convinced pc is Not going to sleep. Monitor does, though.

Came across a Post suggesting:

In Device Manager
System Devices
Intel Management engine
Properties
Power Management Tab
Untick "Allow computer to turn off this device to save power"
Save

Anyone try this ?

Thought it would be worth a try, but have just realized I have an AMD chipset and apparently not Intel.

So, might anyone suggest where this option might be for me ?
Can't find anything equivalent.

Thanks,
Bob
 
Ad

Advertisements

Joined
Apr 22, 2017
Messages
2,640
Reaction score
302
Hi Bob,

do you have the Intel app still installed?, you should remove that first and restart your PC once removed then see if things are okay after that, the app may be the cause of the trouble?. :)
 
Joined
Dec 4, 2017
Messages
61
Reaction score
2
Hello Wolfie,

Doesn't seem like I have anything Intel. All seems to be AMD.
No Intel Management Engine, etc.

Was hoping there might be something equiv., so I could try the suggested
cure, as I outlined above.

Regards,
Bob
 
Joined
Jun 2, 2015
Messages
47
Reaction score
8
Robert~

you mentioned : Untick "Allow computer to turn off this device to save power"

IF IM NOT MISTAKEN .. by this being 'unticked' the device WILL NOT turn off even if you put the computer to sleep .. ( no matter whether you have AMD or INTEL processor)

Mind you, I don't utilize the "sleep option" on my computer .. I generally will ONLY shut it down if i will be away from it for a while (working for the day or going out of town for a few days ) and then power it back up and leave it on until the next time I will be away from it for an extended period of time ... mIne is also a desktop(custom built) .

What you COULD do however is look through your devices in device manager and right click on them and if there is a ANY power management options after the right click .. then CHECK MARK the box that will allow the device to turn off to save power ..

THEN go into you MAIN POWER SETTINGS ... and select whatever plan you want to use and you CAN customize it to you liking as to when your monitor, Hard drive, cpu, etc. shuts down to save power ..

Good luck.
~LoneWolf
 
Joined
Aug 2, 2015
Messages
47
Reaction score
5
I also, unfortunately, got auto sleep problems when I upgraded to 1903.
The dang thing would not go to sleep on its own anymore. Mine is a homebrew Gigabyte motherboard with AMD processor.

Things I tried:
Restore default settings on all three plans-no luck
Using Windows 10 troubleshooter for power sleep issues-no luck,
It thinks I'm using a laptop using batteries when I'm using a tower computer :)
Using on-screen Windows Help feature-no luck
Using antivirus/antimalware programs to detect if the evil code is keeping computer awake-no luck
Using powercfg commands to find anything that could create wake issues for something that is constantly waking and keeping from sleeping-no luck
Tried all suggestions on this web page:
-no luck

It seems to me, Windows has buggered up my settings from previous 1803 upgrade which worked fine.
In fact, I have never had this problem before with any computer/operating system Win98, XP,2000, Vista, Win7, Win8, older versions of Win 10.
Windows can't seem to use settings that I change and switches to different active power plans by itself.

The only solution that worked for me on my tower computer was:
Set setting values exactly the same on each of the power plans, as well as the same settings on any window with simplified settings.

See picture

In that way, MS still buggy code will switch the active power plan by itself,
but still find my working settings that finally after much frustration,
put my computer to sleep. It has now worked correctly for three days now. Monitor off, hard drives off, power supply and motherboard fans off. Just low power state to keep ram memory alive so later when I hit the space key or wiggle the mouse, the computer wakes up. :)
My settings may or may not work for your system. Give it a try if at your wits end.

Come on MS, give us an update to fix this mess.
We should not have to rack our brains for a fix on a 1903 beta.
Thank you, my rant is over.
 

Attachments

Ad

Advertisements

Joined
Mar 9, 2016
Messages
87
Reaction score
6
1. Select the "Start" button in the bottom left hand corner (Windows Icon)

2. Select the "Settings" icon on left side

10371


3. Now select the "System" option from the top left

10372


4. Fifth from the top you should see "Power & Sleep", select this

10373


5. In my version of Windows, on the far right side we see "Additional power settings", select this

10374


6. A new window will open, now locate and select "Change plan settings"

10375


7. Another new window will open, this time we select "Change advanced power settings"

10376


8. We have finally arrived at our destination. This new window provides a number of different settings we want to change if available. Not all will be available on your machine so change as many as you are able to. Expand each section and verify sleep is allowed on each (none of them should say "Never"). The "Turn off hard disk after" for instance should be a lower time than your sleep setting ie: System set to sleep after 30min, Turn off HDD should be set to 20min. Some of the settings can be a bit vague, just try to set all of them to some form of 'power saving' or 'allow computer to sleep'. Typically you will find one in here that is clearly the culprit, for me it was the "USB selective suspend setting" which was set to "Disabled" meaning it wasn't putting any USB devices to sleep so mice, keyboards and headphones were constantly pinging my system to let it know they were active even if they weren't moving. worked like a charm on Citrix VDI

10377


9. Select "Apply" and then close out any open windows, restart the computer and let the system sleep naturally (leave it idle)

Device manager option

There are a TON of devices that could be preventing sleep and unfortunately, it's really hard to pinpoint which one is causing the problem. Our best advice is to simply go through the common ones such as network, display and CPU. The single most common culprit is usually the network devices, so we will cover that below

Network adapter power management

1. Select the "Start" button in the bottom left hand corner (Windows Icon)

2. Type "Device Manager" and select the first option

10378


3. In the new window locate the "Network adapters" option and click the small " > " to open it up

10379


4. Double click the primary network adapter, if you have more than one it's ok to perform these steps on each one if you are unsure which is primary

10380


5. Navigate to the "Power Management" tab

6. Here you will find the option "Allow this device to wake the computer" and we actually want to deselect it. Most people do not need this and it seems a recent update has caused the network

controller to wake the computer or prevent sleep with ANY activity which is not how it was originally designed

10381


7. Select "OK"

8. Close any open windows and Restart the computer

Device manager option continued...

Adjusting this setting will disable your ability to wake the machine using mouse movement or clicking. If this solves the problem of your system not sleeping though, you have to decide which you prefer: A system that won't sleep, or having to wake the system with your keyboard or power button

USB Mouse power options

1. Select the "Start" button in the bottom left hand corner (Windows Icon)

2. Type "Device Manager" and select the first option

10382


3. In the new window locate the "Mice and other pointing devices" option and click the small " > " to open it up

10383


4. Double click the primary mouse in use, if you have more than one it's ok to perform these steps on each one if you are unsure which is primary

5. Navigate to the "Power Management" tab

6. Here you will find the option "Allow this device to wake the computer" and we actually want to deselect it. As mentioned previously, this will disable the ability to wake your system with mouse movement or clicks

10384


7. Select "OK"

8. Close any open windows and Restart the computer
 
Joined
Dec 4, 2017
Messages
61
Reaction score
2
Hi,

Thanks for all the hints.
Will try them all.

Appreciate the help.

Best regards,
Bob
 
Ad

Advertisements

Joined
Aug 2, 2015
Messages
47
Reaction score
5
Update:
I saw there was a new Win 10 follow up update (KB4505903), to fix bugs in 1903.
In their notes they say something about fixing the issue with a computer using Bluetooth, not going to sleep,
So I reset (Restore default settings) for all Power option plans, downloaded and installed the new update fix, restarted.

Behold, sleep is now working correctly even on default settings where it would not work previously.

Thank you, Microsoft. Going forward, it still would be better to work out all the bugs before a big update, then release it. :)

@Robert11 This update may fix computer sleep problems with other users computers including yours,
for I don't even use Bluetooth, and it still fixed mine. :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top