SOLVED Cannot Set Google Chrome as Default Browser

Apr 5, 2017
Reaction score
Sunday the newest Windows 10 update first tried to lock me out of my computer by not recognizing my local login (the only login I've ever used for Windows for as long as I've been a windows user). When I finally was able to get back into my local account, all of my default programs have been reset to Microsoft defaults.

Let me reiterate: I have never used anything other than a local login to access Windows on all of my PCs. I am not interested in using a Windows Live login to log into my desktops or laptops, nor am I interested in using Windows to sync my devices.

I have tried to set my default browser back to Chrome (which it was until this latest update) and set the video player to something other than a microsoft product using the Choose default apps Control Panel (because ALL requests to set the default web browser lead here, regardless of whether it's through "Default Apps" or the "Make Google Chrome the default browser" button in Chrome settings).

I have disabled my virus protection and tried resetting the default browser with exactly the same results: no success. So it's not security that's blocking me from setting Google Chrome as my default browser.

I have right-clicked .htm and .html files and selected "Choose another app" and then chose Google Chrome and the "Always use this to open the .htm (or .html) files" for each respectively. All .htm and .html links on my desktop still show as Microsoft Edge files. If I double-click a file that ends in .htm or .html, however, it's opened in Google Chrome.

Unfortunately, if I'm trying to open a link that I've saved in Microsoft Excel, however, like the following:


the link is still opening in Microsoft Edge.

Is there any fix for this?


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question