Can't safely eject external hard drive and icon doesn't show up in task bar?


Joined
Nov 28, 2015
Messages
5
Reaction score
0
I just received my MSI laptop with Windows 10 and I'm still feeling around on how to use the new OS (upgraded from Windows 7). I plugged in my ext. HDD and something popped up asking something along the lines of "What do you want to do with this?". I was like "Okay, everything's going fine so far."

The problem came when I wanted to eject my HDD though. I couldn't find the icon in the little notifications area with the arrow. I couldn't eject the HDD from "This PC" either. In the end, I just unplugged it, since there wasn't anything too important on it.

I've tried enabling "Quick Removal" in the device manager, but that checkbox doesn't even show up. Instead, it's replaced with the "Write-caching policy" options. I've also tried turning the notifications on in the taskbar, but that doesn't work either. I turned on task manager, safely eject..., and location, but none of them show up. I've restarted my computer as well. What is the problem and how do I fix it?
 
Joined
Jul 31, 2015
Messages
208
Reaction score
28
On mine, I click the up arrow (inverted V) on the notification bar and, if a hard disk is plugged in, I will get what looks like a USB stick icon to show. Right click on that and you can eject your hard disk.

What do you see?
 
Ad

Advertisements

Joined
Nov 28, 2015
Messages
5
Reaction score
0
What do you see?
That's the problem. I've seen that on my old computer countless times. In fact, I see it even as I plug in my DataTraveler on this new one. However, when I plug in my hard drive, it doesn't show up at all. I don't think that Windows recognizes that my HDD can be ejeceted :/
 
Joined
Jul 31, 2015
Messages
208
Reaction score
28
Well, I tried it with my external USB 3 2Tb hard drive and it worked fine.

Can you give a bit more detail on what you plugged in, where you plugged it in and maybe what appears in device manager? That may give us a bit of a clue.
 
Joined
Nov 28, 2015
Messages
5
Reaction score
0
Okay, so when I plug in the 500 GB hard drive (Matsunichi model DM256), the file explorer opens up and shows me the files on the hard drive. It doesn't ask me to open it or anything, or have the option to "show folders" etc. that you would normally get from a USB.

This is the screenshot of my icon tray while it is plugged in.


I plugged it into one of the USB 3.0 ports on the side of my computer.

Here's what it shows in the device manager.


I know that it's supposed to have the "Quick Removal" option instead of this "Write-cache" stuff.

Finally, this is what it shows when I try to right-click the drive.


I just can't seem to find the option anywhere at all. It works fine for when I have my regular USB stick plugged in.
 
Last edited:
Joined
Jul 31, 2015
Messages
208
Reaction score
28
How weird. I am away at the moment. When I am home I will try it with a "real" hard disk connected to a Sata-USB connected.
 
Ad

Advertisements

Joined
Nov 28, 2015
Messages
5
Reaction score
0
UPDATE: I found out that it is a particular port that does not recognize the devices. I have 2 USB 3.0 ports, and only one of them allows me to eject. The other one doesn't recognize my USB or the HDD. Should I get the laptop replaced? It still allows me to transfer data. It just won't let me eject...
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top