Epsom Perfection V550 connection problem


Joined
Feb 23, 2020
Messages
4
Reaction score
0
Hi
I have the above scanner which works fine some of the time. However, now & again it appears to lose its connection.
I then have to go through a series of operations to get it to work. These include (but are not always successful):
Powering the scanner off & on.
Disconnecting/reconnecting the usb cable
Changing the usb to another port
Re-installing the Epson Scan software & drivers.
Restarting the PC
A combination of the above.
I use both the Epson Scan software & VueScan.
I have no idea why this happens. I keep everything up to date but it makes no difference.
I have just wasted 45 minutes getting it to work again.
Any suggestions
 
Ad

Advertisements

Joined
Apr 22, 2017
Messages
4,323
Reaction score
564
Hi David,

first off, are you running the latest version of Windows 10?:


Do you have the latest drivers etc?:

https://www.epson.co.uk/support#drivers_and_manuals :)
 
Joined
Feb 23, 2020
Messages
4
Reaction score
0
Yes, I have the latest Windows version & Epson drivers.
This has been happening for a year or more now.
 
Joined
Feb 23, 2020
Messages
4
Reaction score
0
It's not the Windows version since this has been happening during the last 2 or 3 versions.
The latest drivers are dated 2018 so I must have reinstalled them several times since then.
At present it's working fine albeit taking me the best part of an hour.
From past experience it'll work fine for a month or so now & then I'll have to go through it all again.
 
Ad

Advertisements

Joined
Sep 26, 2017
Messages
2,248
Reaction score
431
I have seen issues with older USB 2 units not working properly when plugged into USB 3 ports on the computer such as an HP All-in-One losing connection after printing half a page, using actual USB 2 ports worked fine. USB 3 is supposed to be backward compatible with USB 2 devices but can be hit or miss.
 
Ad

Advertisements

Joined
Feb 23, 2020
Messages
4
Reaction score
0
Yup, as I said in my original post I use Viewscan from Hamrick as well as Epson Scan & as with the rest I keep them up to date.
The scanner connection USB2 which I use to no avail.
Oh well, thanks for your help.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top