How to Turn Off Windows Update


Joined
Sep 13, 2019
Messages
8
Reaction score
0
Hi everyone,

I have Asus i3 laptop that comes with Windows 10.

I have tried a lot to disable the automatic update, because every time it consume the data.

Even though, I set to 5GB monthly update, it's keep downloading the update and restart the PC :(

Now, the automatic update option has been disabled by the system itself (under Services).

Can someone please guide how to restrict the download.
 
Ad

Advertisements

Joined
Feb 22, 2014
Messages
1,382
Reaction score
268
Around March of 2020 MS will release a build splitting updates. Security update if I read correctly will be the updates automatically updated. I'm not certain but I'm thinking we will gain a choice once again for the other updates.

I know that is not helping you now. And I certainly feel your pain. But it at least gives hope for the future.

 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,214
Reaction score
1,000
What version of Windows 10 do you have?

Home, Professional, Enterprise?

Home users cannot disable updates, however Enterprise users definitely can, and given professional editions also includes the Group Policy Editor, it may be possible the solution I have in mind would work for them too.
 
Joined
Sep 13, 2019
Messages
8
Reaction score
0
What version of Windows 10 do you have?

Home, Professional, Enterprise?

Home users cannot disable updates, however Enterprise users definitely can, and given professional editions also includes the Group Policy Editor, it may be possible the solution I have in mind would work for them too.
I have home version which comes with Asus Laptop.

The problem is every-time it download the updates and cross the limit (i.e. 5 gb monthly)
 
Joined
Nov 19, 2013
Messages
4,566
Reaction score
889
I have no way of testing how this works, but have you tried this option in the settings - updates?

1569397278641.png
 
Ad

Advertisements

Joined
Nov 28, 2015
Messages
80
Reaction score
10
First ensure you have metered connection set if you haven't already...

Settings > Network & Internet. On the left, choose Wi-Fi. On the right, click on your Wi-Fi connection. Move the slider for Metered connection to On.

(Replace Wi-Fi with Ethernet in above steps if using an Ethernet connection.)

Then follow davehc's directions.

I have no way of testing how this works, but have you tried this option in the settings - updates?

View attachment 10573
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top