Mouse driver missing?

Sep 16, 2023
Reaction score
8 yr old desktop w/ i5-7600K (still running smooth)
Windows 10 Home Ed.

I use a wireless Logitech mouse, and I recently tried to swap it for a new Logitech. I plugged in the second unifying receiver while the first one was still plugged in (maybe not ideal but I wasn't thinking), and I lost all mouse function. I tried every configuration of old and new mouse and receiver, as well as an HP mouse, but none worked. Running through Logitech Unifying software, both mice were detected ok, but still no function. I couldn't find anything on Logitech's website that looked like a driver I could download.

In Device Manager, I didn't find a Mouse/Pointer section, but I did find a Logitech USB Device and other items that might have possibly been generic mouse drivers under Human Interface Devices. I tried updating all of them then later uninstalling all of them and rebooting. I later tried the usual tricks in Command Prompt (SFC scannow, DISM checkhealth & scanhealth & restorehealth) to no avail. I've also tried swapping batteries, toggling mouse power, using different USB slots, reinstalling Logitech utility, disabling Realtek HD Audio, retrying solutions in Safe Mode, updating Windows 10, using a restore point (I was a dummy and didn't have one before issues, so only went back to the start of troubleshooting attempts), banging my head against the wall, and threatening my PC. I'm out of ideas.

Can anyone think of anything else I can try before doing a fresh install of Windows?
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question