Windows 10 intermittently not sleeping automatically


Joined
Aug 10, 2015
Messages
10
Reaction score
2
My power scheme is set to lock the screen after 4 minutes, turn display off after 5, sleep (S3) after 10 (hybrid sleep disabled). Auto-sleep usually works a few times after reboot, but then fails: no screen lock, no display off, no sleep. No new apps have been launched in the meantime. Then, perhaps an hour later, auto-sleep starts to work again for a few times, then fails again. (Manually suspending or resuming the PC always works properly.)

Powercfg /requests consistently lists nothing in any category. Powercfg /lastwake just shows the keyboard activity that I used to wake the computer from its last sleep. The network adapter's wake-this-computer box is deselected in the device manager. Media streaming is not enabled. There is no homegroup. Dism scanhealth and checkhealth show no errors. Checking the system drive and all data drive shows no errors.

I've tried restoring the default power settings for all plans, then reestablishing my own settings, but the problem persists.

Manually putting the PC to sleep is not a viable workaround, in part because the PC wakes for some scheduled tasks (especially overnight) and needs to go back to sleep (which it isn't doing).

Latest updates, drivers, and BIOS are all installed. Motherboard is ASRock Z77 Extreme4.

It would be helpful to know if anyone else has this problem despite nothing shown in powercfg /requests. It would also be helpful to know if anyone else has the Z77 Extreme4 and does NOT have this problem with Windows 10.

There are tools to show what keeps a PC from sleeping when idle (powercfg /request), and to show what wakes an idle PC (powercfg /lastwake). But are there any tools to show what keeps an idle PC from being recognized as idle?
 
Ad

Advertisements

Joined
Aug 10, 2015
Messages
5
Reaction score
0
I'm looking for the same answer as you, Gary. I was told Auto Updates would prevent the computer from entering sleep mode, but I disabled that and it made no difference. Resetting sleep parameters in Settings did nothing. I have an HP Pavilion 20, had no problem with the upgrade from 8.1 to 10, but the failure of auto sleep mode is a real pain.
 
Joined
Aug 10, 2015
Messages
10
Reaction score
2
Yes, I forgot to mention that my PC too was auto-sleeping properly prior to upgrading from 7 to 10.
 
Joined
Aug 10, 2015
Messages
10
Reaction score
2
Solved.

It turns out I had two USB joystick devices that for some reason were often (though not always) in a mode of sending frequent signals that reset the PC's idle-time counter.

I don't know if the problem's recency is coincidental or if the drivers behave differently under Windows 10. In any case, it's easy enough to work around the problem by unplugging the devices when I'm not using them.

(Using an idle-time monitoring utility helps figure out problems like these, because you can see the idle-time reset immediately instead of having to wait and see if the screensaver kicks in a minute later. It would be even better if Windows provided a good way to directly see what program or device was responsible for resetting the counter.)
 
Joined
Aug 10, 2015
Messages
5
Reaction score
0
Glad you got a solution Gary, but honestly, you shouldn't have to disconnect anything in order for proper computer actions to occur. I have read on other sites that the "no sleep mode" problem is common. I've got to believe the geeks are working on it and that a fix is on the way. Other than this issue, my transition to Win 10 has been fairly painless.
 
Joined
Aug 10, 2015
Messages
10
Reaction score
2
Glad you got a solution Gary, but honestly, you shouldn't have to disconnect anything in order for proper computer actions to occur.
I agree. But it could be my USB devices' fault rather than Windows 10's fault.
 
Ad

Advertisements

NAL

Joined
Jul 5, 2015
Messages
6
Reaction score
3
Gary, you solved my problem. It was my Wingman Joystick causing the monitor to stay on!
Thank you, thank you.
 
Joined
Aug 10, 2015
Messages
3
Reaction score
1
Thanks Gary your post help me find out that it was my USB camera. So it looks like it is a 10 thing as it is different devices causing the behavior.
 
Joined
Aug 12, 2015
Messages
2
Reaction score
0
I've got the same problem - I've tried to elminate anything that might be causing it to stay awake, can't identify a thing. I've re-set the power settings, even tried switching my screen saver, no use. Screen saver never comes on and it won't go to sleep - have to do it manually, which is a pain... Any ideas anyone?
 
Joined
Aug 10, 2015
Messages
10
Reaction score
2
I've got the same problem - I've tried to elminate anything that might be causing it to stay awake, can't identify a thing. I've re-set the power settings, even tried switching my screen saver, no use. Screen saver never comes on and it won't go to sleep - have to do it manually, which is a pain... Any ideas anyone?
Have you tried the ideas already mentioned: Unplugging your USB devices? Using a utility to monitor your idle-time counter?
 
Joined
Aug 12, 2015
Messages
2
Reaction score
0
Have you tried the ideas already mentioned: Unplugging your USB devices? Using a utility to monitor your idle-time counter?
Only things I have on USB right now are the keyboard and the mouse - I'm using a desktop all in one. Printer is wireless but it's turned off. I also noticed that the Settings function doesn't work - click on the icon and nothing happens. Cortana isn't working, and I have no search window...
 
Ad

Advertisements

Joined
Aug 10, 2015
Messages
5
Reaction score
0
Oddly, as of this morning, there is no manual Sleep choice in settings. It was there yesterday, so I have to assume MS is dinking with the issue. Sounds as if there are lots of things we will have to change or even eliminate in order to use this "upgrade" OS. Having to disconnect peripherals or other USB devices in order for the computer to sleep is not an improvement, it's a pain. I'm down to shutting down the unit when I'm not on it. Couldn't all the gurus touting Win 10 see this before they opened their keyboards to brag on it?
 
Joined
Aug 10, 2015
Messages
10
Reaction score
2
Oddly, as of this morning, there is no manual Sleep choice in settings. It was there yesterday, so I have to assume MS is dinking with the issue.
Sorry, what manual Sleep choice are you referring to? All my sleep-related options look the same today. My PC hasn't received any Windows updates for a couple of days; has yours?
 
Joined
Aug 10, 2015
Messages
5
Reaction score
0
I have auto updates shut off. Previously, if I chose the "Shut Down" button from the lockscreen or the start screen, I had the choice to "Sleep", "Shutdown", or "Restart". "Sleep" has disappeared.
 
Joined
Aug 10, 2015
Messages
10
Reaction score
2
I have auto updates shut off. Previously, if I chose the "Shut Down" button from the lockscreen or the start screen, I had the choice to "Sleep", "Shutdown", or "Restart". "Sleep" has disappeared.
Not clear how MS could be "dinking with the issue" without installing any updates. In any event, I checked my lock screen and the Sleep option is still present for me.
 
Joined
Aug 10, 2015
Messages
5
Reaction score
0
I agree, Gary, that no changes to my system should be possible with updates shut off. But, the sleep option, present on your system, has disappeared from mine. At this point, I can find no way to initiate sleep mode, thus I have to shut the unit down overnite. All of this fails to explain why the computer will not enter sleep mode even though I have changed those parameters in Settings several times. Something in the OS is preventing this from happening. Other threads on this and other forums indicate to me that the issue is not mine alone. As with all issues concerning upgrades, a solution will eventually come. I'm just a bit impatient, that's all.
 
Ad

Advertisements

Joined
Sep 7, 2015
Messages
1
Reaction score
0
Solved.

It turns out I had two USB joystick devices that for some reason were often (though not always) in a mode of sending frequent signals that reset the PC's idle-time counter.

I don't know if the problem's recency is coincidental or if the drivers behave differently under Windows 10. In any case, it's easy enough to work around the problem by unplugging the devices when I'm not using them.

(Using an idle-time monitoring utility helps figure out problems like these, because you can see the idle-time reset immediately instead of having to wait and see if the screensaver kicks in a minute later. It would be even better if Windows provided a good way to directly see what program or device was responsible for resetting the counter.)
Gary

It would be super helpful if you would link to the Idle time monitor you are talking about since a simple Google doesn't turn up anything. The
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top