Window's Update issues after reinstall and more

Mar 8, 2021
Reaction score
Hi everyone,

New here, but have been an observer to the forum for many years.

Apologies I think I have this in the wrong forum, but unsure how to move or delete it

So long story short hopefully. Have an Acer with Windows 10.

I had to do a reinstall of windows using my USB recovery drive, however something happened during that and it didn't work which then meant that I had to enter the BIOS to make sure that the laptop was booting up on start-up to install windows. After getting that done and having to quickly remove the USB when it restarted so it installed Windows rather than reboot USB. So I now have windows installed.

I now seem to have a number of multiple issues. The first one being when I go to the windows update, I am getting multiple updates but also "Your device is missing important security and quality fixes" I had a look online and saw about using the Windows Update Troubleshooter which I did but didn't fix the issue. I also saw about using the Command function and doing DISM.exe /Online /Cleanup-image /RestoreHealth followed by a sfc/ scannnow , I checked back with Windows update but again it made no difference and the message was still there.

Most of the updates have been installed but I am still unable to install this update

2020-02 Cumulative Update for Windows 10 Version 1803 for x64-based Systems (KB4537762) and am still getting the Your device is missing important security and quality fixes.

I also tried going into gpedit.msc through Windows Key and R and when I hit enter I got "Windows cannot find gpedit.msc. Make sure you've typed the name correctly then try again." It had been typed correctly so not sure what has happened, I was able to download a gpedit enable for Windows 10 and installed that and now seem to have access to that. I tried changing the telemetry level to enable and enhanced but again this didn't fix the "Your device is missing important security and quality fixes".

Have also tried Manually Reset Windows Update Service through the command function as Admin but when I type "net stop wuauserv" its saying the service could not be stopped.
Ran a batch file to reset WU services and while it did stop the windows update on the command, I still am getting the same message "Your device is missing important security and quality fixes.

The laptop is extremely slow at the moment but I am hoping that is due to all the rubbish that's on it after the reinstall of windows and just the overall rebuilding of it.

I would be eternally grateful if someone could help or point me in the right direction on how to get this fixed and if there is anything else I should be checking to make sure the laptop is going to run smoothly in future.

I look forward to hearing from you

Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question