Word 2007 changes language


Joined
Nov 24, 2015
Messages
2
Reaction score
0
When typing a document the language changes to French frequently. I have the language set as English (Canada) with US English keyboard. I thought using the US keyboard would solve this problem but it hasn't. How can this problem be stopped?
 
Ad

Advertisements

Joined
Sep 26, 2017
Messages
3,043
Reaction score
588
I rebuilt a Notebook with a new SSD several months ago that came from Canada [a few hundred miles North of me]. I reinstalled what I could since I didn't have all the necessary programs and their serial numbers [lady is Canadian but man is USA] so I used the English (Canada) Windows and installed LibreOffice, didn't see any issue in what little I did in typing. Haven't had any word on problems, have to ask her when I see her again.

As a diagnostic I'd do the same with yours, install the free LibreOffice and see if the issue is only with Word or with other programs. It can work with Word .doc and .docx files. [Office 2007 was when the file formats changed and have the x added to the extension.] www.libreoffice.org
 
Joined
Jan 11, 2022
Messages
10
Reaction score
4
I think this happened because your MS word file is selected to auto spellcheck to French. And you need to change it.
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
6,196
Reaction score
1,256
I am also in a position where I need accessibility to two languages.
I use Word 2016, which has the setting as under. Maybe you have something similar. It could be the problem?

1644133196096.png
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top