After upgrade from W7 to W10, Event viewer has warnings regarding WMC

Discussion in 'Windows 10 Support' started by Tech Geek, Aug 1, 2015.

  1. Tech Geek

    Tech Geek

    Joined:
    Aug 1, 2015
    Messages:
    2
    Likes Received:
    0
    Location:
    Medicine Hat, Alberta
    As the title says, after upgrading Windows 7 (Home Premium) x64 to Windows 10 Home x64, I've noticed that there are warnings in the Event viewer every time the system boots regarding Windows Media Center. See below:

    [​IMG]

    This is my third computer that I've upgraded. The other two systems were Windows 8.1 systems, so they didn't have WMC, so I haven't run into this. As I understood it, when Windows 7 was upgraded, the Windows 10 installer was supposed to remove WMC. One would have thought that it would remove all references to it as well.

    I took a look in the Task Scheduler and couldn't find anything associated with WMC. I ran CCleaner on the registry thinking that maybe something in the registry was attempting to start WMC. This didn't help either.

    The upgrade itself went pretty easy, but this system seems to have quirks that the first two don't have, this being just one of them. I won't list the other problems since I don't believe they have anything to do with this problem.

    Has anyone else seen this? Anyone have a solution? I'd just as soon not have to do a clean install if I can avoid it.
     
    Tech Geek, Aug 1, 2015
    #1
    1. Advertisements

  2. Tech Geek

    Plekuz

    Joined:
    Aug 3, 2015
    Messages:
    1
    Likes Received:
    0
    I had the same warnings and could not find them in the Task Scheduler.

    However, I did find around 24 invalid tasks in the registry at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks. So if you are not afraid to mess around in regedit than the solution is as follows:
    1. Start regedit (run as administrator)
    2. Go to the fore mentioned key
    3. Export the key just in case we make an error along the way
    4. From this key search for "Media Center"
    5. Remove every complete entry under the fore mentioned key containing this text (should be about 24 of them)

    What I also did was at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows remove the complete Media Center entry (again export first to prevent mishaps).

    After a reboot I no longer had the task scheduler warnings concerning Media Center any more. Hope this helps for you as well.
     
    Plekuz, Aug 3, 2015
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.