Cannot make Firefox browser the default browser

SOLVED Discussion in 'General Discussion' started by jrj350, Sep 3, 2018.

  1. jrj350

    jrj350

    Joined:
    Jul 22, 2015
    Messages:
    121
    Likes Received:
    7
    Location:
    Beer Sheva, Israel
    I have tried all the given solutions and none of them work. No matter what I do, I cannot make Firefox browser the default browser.
    Thank you
     
    jrj350, Sep 3, 2018
    #1
    1. Advertisements

  2. jrj350

    Norton

    Joined:
    Feb 18, 2016
    Messages:
    2,807
    Likes Received:
    611
    You don't say what given options you have tried. Try this if you haven't already done so.
    Open Settings Click on Apps > Default Apps > scroll down and select "Set apps by default", select Firefox. Good Luck!
     
    Norton, Sep 4, 2018
    #2
    1. Advertisements

  3. jrj350

    Aputernut

    Joined:
    Jul 23, 2015
    Messages:
    80
    Likes Received:
    24
    Location:
    Florida
    Have you tried turning off edge, then you will get the option to make FF browser default, like I did.
     
    Aputernut, Sep 4, 2018
    #3
  4. jrj350

    jrj350

    Joined:
    Jul 22, 2015
    Messages:
    121
    Likes Received:
    7
    Location:
    Beer Sheva, Israel
    I finally solved the problem by resetting Windows 10. Now I didn't do a reset just for the Firefox problem. I started noticing more glitches while running the system. I decided to just do a complete reset and by golly, the glitches disappeared and as a by-product I got Firefox to set as my prime browser.
    Thanks for the replies .
     
    jrj350, Sep 6, 2018
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.