Can't see NAS in Explorer?


Joined
Dec 21, 2015
Messages
1
Reaction score
0
Can't see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!
omiklik, absolutely brilliant stuff, This worked like a charm, after wasting hours trying to fix it, and a lot of trawling through different Google search responses.
I bow in your presence.
To Microsoft, I fart in your general direction.
 
Joined
Dec 22, 2015
Messages
2
Reaction score
0
Can't see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!
Greetings-- Interestingly I can actually path to my NAS, i.e.; \\NASMEW3 BUT cannot see it under my network until I path to it... once I path to it does show under network until I close out. SO, my question is-- your steps-- do they effect the performance of the Server Message Block (SMB), in other works are you reverting to the SMB1 vs SMB2? Thanks so much! Metrail
 
Ad

Advertisements

Joined
Dec 26, 2015
Messages
1
Reaction score
1
I was just wanting Windows Explorer to show my NAS drive any time I opened it. This was to make it easily accessible like it was in Windows 7 & 8.1.

This solved the problem for me....

I just went to the Windows Firewall/Advanced : by going to "Control Panel -> System and Security -> Windows Firewall". Then, click or tap Advanced settings.
Left pane select "Outbound Rules". Right pane select "New Rule"/Type of rule=Program/"Program Path": Browse to explorer.exe(should be in C:\windows. Next/Allow the connection/NEXT/Select only private/NEXT/Name it whatever you want/NEXT.
Done
 
Joined
Dec 22, 2015
Messages
2
Reaction score
0
I was just wanting Windows Explorer to show my NAS drive any time I opened it. This was to make it easily accessible like it was in Windows 7 & 8.1.

This solved the problem for me....

I just went to the Windows Firewall/Advanced : by going to "Control Panel -> System and Security -> Windows Firewall". Then, click or tap Advanced settings.
Left pane select "Outbound Rules". Right pane select "New Rule"/Type of rule=Program/"Program Path": Browse to explorer.exe(should be in C:\windows. Next/Allow the connection/NEXT/Select only private/NEXT/Name it whatever you want/NEXT.
Done
Dtoolman-- Thanks so much for your posting! Unfortunately, this did not work on my Windows 11 Pro machine. So far I'm just living with my desktop shortcut, i.e.; \\NASMEW3, it seems like the best workaround without having to degrade the SMB2. Merry Christmas ~ Metrail
 
Joined
Jan 1, 2016
Messages
1
Reaction score
0
Can't see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!
Thank you so much, this has been driving me nuts for a month now. Finally I can see my Zyxel NSA310. Brilliant
 
Joined
Jan 5, 2016
Messages
1
Reaction score
0
My computer just did the November update to Windows 10 overnight and I've since been unable to see our NAS in file explorer, although I can access it through \\wdmycloudex2\Data. I tried the suggestion (1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done) and it worked in that I could see the NAS but none of my Microsoft programs work (they crash as soon as opened). Please provide the "undo" instructions (revert to Windows 10 default) for #2 and #3.

Thanks!
 
Joined
Jan 12, 2016
Messages
1
Reaction score
0

Can't see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!
Thanks for the tip ... worked like a charm !

Omiklik, thank you so much! You really know your computers! I can't say it any better than Allan H - "absolutely brilliant stuff, This worked like a charm, after wasting hours trying to fix it, and a lot of trawling through different Google search responses.
I bow in your presence.
To Microsoft, I fart in your general direction"
 
Joined
Jan 13, 2016
Messages
2
Reaction score
0
I now have the same problem as CindyP. I was able to see my NAS and connect until some further Windows 10 updates and looking for a solution led me here. I did:

1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart

Now I can see the NAS in the network section of Explorer but I cannot connect to it. I get the following error:

"\\NAS is not accessible. You might not have permissions to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The remote procedure call failed and did not execute"


I don't have any programs on this PC yet to test if they fail as per CindyP's report but as the config changes definitely don't work I would like to undo them. Omiklik (or anyone else), do you have the commands to revert to the default configurations?
 
Joined
Jan 13, 2016
Messages
2
Reaction score
0
This is frustrating! Thing is I have 2 identical Win10 tablets (both brand new) and I only made the sc.exe changed to 1 of them. I was able to map the NAS network drive using the static IP address on the other but I cannot map it on the one with the sc.exe changes. Need to know how to revert....help

OK.... Googled the commands and came up with the following advice:

To disable SMBv2 and SMBv3 on the SMB client, run the following commands:
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled


To enable SMBv2 and SMBv3 on the SMB client, run the following commands:
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto


This was from here: https://support.microsoft.com/en-us/kb/2696547
So Omiklik's advice was to disable SMBv2 and SMBv3. Just needed to run cmd as administrator again, execute the commands to enable, restart and all back to normal. Normal being that I cannot see my NAS but I can map to it. I can live with that.
 
Last edited:
Joined
Jan 13, 2016
Messages
1
Reaction score
0
Can't see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!
Brilliant! Solved my problem although not sure what I've actually done...
 
Joined
Jan 21, 2016
Messages
1
Reaction score
0
Can't see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!
This worked on 2 of 3 machines, still searching on the one machine problem
 
Joined
Dec 28, 2015
Messages
2
Reaction score
0
Run "sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi" is not a good idea. I have tryied it. n the begining, this work. But sometime latter, when you click on a device on the network pannel, Windows explorer says "path not found". :-(
 
Joined
Feb 7, 2016
Messages
1
Reaction score
0
Can't see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!
I signed up for the Forum, just so I can thank you for this post!!

I have no idea what this does, or what the parameters are, but this not only fixed my NAS viewing problem, it also fixed my server viewing problem at work.

Thank you, thank you, THANK YOU!

I found more info about this in another forum:

The fall update broke the SMB (Server Message Block) component of the OS. Below is a work around that will fix your issue until such time as Microsoft patches this issue.
1. Open an administrator cmd prompt.
2. type the following: (press Enter after each line)

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

then Restart the computer

To reverse this change and re-enable SMBv3 run the following commands at at the elevated command prompt

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto

then Restart the computer
 
Last edited:
Joined
Feb 27, 2016
Messages
21
Reaction score
1
Can't see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!

This worked for me to ... can you explain what it does (Just trying to understand)??? Is there a way to do a similar thing with menus and control panel access?
 
Joined
Feb 10, 2016
Messages
4
Reaction score
1
Can't see NAS drives in your network on Windows 10? Here is the solution:
1/ run cmd as admin
2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
3/ sc.exe config mrxsmb20 start= disabled
Restart and you are done!
That fixed the problem for me as well. Thank you. Thank you. Thank you! Now, one more request: can you explain what that series of commands did?
 

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
12,051
Reaction score
1,913
Not absolutely positive but it looks to me like you're using the
ServiceCommand to Configure how a service behaves.
In this case by telling LanManWorkstation to use SMB (Server Message Blocks) version 1
AND
Disable SMB version 2
How to enable or disable SMB protocols on the SMB client
Windows Vista, Windows Server 2008, Windows 7, Windows Server 2008 R2, Windows 8, and Windows Server 2012
Note When you enable or disable SMBv2 in Windows 8 or in Windows Server 2012, SMBv3 is also enabled or disabled. This behavior occurs because these protocols share the same stack.

To disable SMBv1 on the SMB client, run the following commands:
sc.exe config lanmanworkstation depend= bowser/mrxsmb20/nsi
sc.exe config mrxsmb10 start= disabled

To enable SMBv1 on the SMB client, run the following commands:
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb10 start= auto

To disable SMBv2 and SMBv3 on the SMB client, run the following commands:
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled


To enable SMBv2 and SMBv3 on the SMB client, run the following commands:
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto

Notes
You must run these commands at an elevated command prompt.
You must restart the computer after you make these changes.
SOURCE: https://support.microsoft.com/en-us/kb/2696547
 
Last edited:
Joined
Apr 13, 2016
Messages
1
Reaction score
0
Thank you, Thank you, Thank you!! this worked like a charm for me!!
Thanks Bernt!!! Worked also like a charm, showed up after reboot like it was supposed to be there in the first place. My setup is a wireless connection to my router >> NAS, as well as an ethernet connection to another router routing through a VPN. Lots of fun but this was the last setup success... Thanks a lot!
 
Joined
May 21, 2016
Messages
1
Reaction score
0
I have a similar problem after I reinstalled to Windows 10 Pro. Thank you so much guys!
 
Ad

Advertisements

Joined
Jun 1, 2016
Messages
2
Reaction score
0
This solution worked for me BUT the problem would periodically reappear. I finally determined that whenever the computer came out of sleep mode I could not access the NAS drive by name, only by IP Address. Since I'm using a desktop, I set Sleep to Never in Power Settings and this seems to be working as a permanent fix.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top