Check your Windows Defender protection engine version


Bif

Joined
Oct 17, 2015
Messages
1,167
Reaction score
440
Update:
I have pinned the new fancy Security Centre to my task bar and Bob's your uncle!
I'm thinking that @cyclist had the old (original) Defender program pinned thus clicking it would result in the old Antivirus UI opening and not the new Security Centre UI.
Clear as mud!:confused:
 
Ad

Advertisements

Joined
May 1, 2015
Messages
57
Reaction score
3
Hi Bif,
I was reading your exchange with davehc when it occurred to me that I did not try to open the Windows Security center from my taskbar. And when I tried this just a few moments ago the new Security Center or your Attachment
5686 opened in the manner I expected with this Version of 1703. So I went to my taskbar and clicked on security icon and it opened to the new Windows Security Center. Next, just verify, I opened the Settings-Windows Defender and click on the Open Windows Defender Security Center tab and the new Security center UI opened. I hope this clear as mud. Try it see and see if it works for you. On a previous post to you I ID the version detail that is on my system. I hope this helps. Thank you.

Yes Dave, left photo is pinned to task bar...from @cyclist OP on this matter, he stated that clicking on the old Defender task bar icon brought up the new Security Centre UI...if I understood it properly.
This is all probability for not, but would like to know if anyone else gets these same (or different) results.
 

Bif

Joined
Oct 17, 2015
Messages
1,167
Reaction score
440
@cyclist, all opens as it should now...but the confusion from my end was that I had a remnant (old) Defender icon on my taskbar, for whatever reason it did not update to the new Security Centre with the latest cumulative.(although the Security Centre was accessible from search) I've since removed that old icon from the task bar and replaced it with the new one, interestingly..that old icon and the old UI that showed when clicked on has entirely vanished from my machine..a possible if ever so slight glitch in the upgrade/update process I'm assuming.
But as I said all is good now.

Cheers
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top