How do I switch OFF Windows update - Permanently?


Joined
Aug 15, 2015
Messages
53
Reaction score
3
I have network issues with Windows 10 1903 and versions following (ie 1909) and wish to stop the automatic update feature, As it is every time it automatically updates I lose all network connectivity, almost completely. ie it connects to my router gets an IP address then fails to connect to the internet or any machines on my network. Roll-back to 180x and no problems.

I've tried everything bar a completely new install of the OS with the obvious issue of having to reinstall software afterwards. All in a thread on the Network area of the forum. Nothing obvious works - USB network adapters, switching off all firewalls etc.

I wish to stop this automatic feature as I am happy where it is and will be getting a new PC soonish anyway. I've tried to stop the update by disabling two services - the "Update Orchestra Service" and "Windows Update" which seem to control the search for and installation of new updates for software. Unfortunately I have found that for some reason these seem to switch themselves on at random times and I find the PC going back to updating automatically. It means that I find myself having to do a rollback at least once a week - a complete waste of time.

How do I stop the windows update service - PERMANENTLY?
 
Ad

Advertisements

Joined
Sep 26, 2017
Messages
2,331
Reaction score
456
There probably are some settings in the Pro version of Win10 and Update & Security but we don't know if that is what you are running.

When I joined the Technical Preview [later became Insider Preview] it was fairly well advertised by reviewers that Win10 would be WaaS, Windows as a Service, constantly being updated. That process has been adopted by software programmers as SaaS, Software as a Service, more known as a Subscription.
 
Joined
Aug 15, 2015
Messages
53
Reaction score
3
Windows Pro 10, Version 1809 build 17763.1039

not running the Windows Firewall or Defender, using Eset Internet Security 13.1.16.0

I just want to wake up in the morning and not have to reset my machine back to the prior version because it wasted system resources and SSD life by updating while I was asleep.
 
Joined
Aug 15, 2015
Messages
53
Reaction score
3
It is seldom left on unless running a backup (twice a week). It is either switched off or put into hibernation for speed of use the next day. What seems to happen is that auto update switches itself on (despite the services being disabled) then it wakes itself up around midnight and does an update on its own.
 
Joined
Nov 19, 2013
Messages
5,473
Reaction score
1,121
Why not, first, get back up to date. Should be


and then use the timer so that the updates are more convenient to you

The Internet problem is a mystery. I also switch off several computers at night, but never have your issue.

Have a look at the properties, and under the power management tab of the ethernet adapter.

1585630943883.png
 
Ad

Advertisements

Joined
Aug 15, 2015
Messages
53
Reaction score
3
My only problem with windows updates is that I want to stop them happening as my computer is unable to connect to the internet with build 1903 or 1909. Every time it decides to update I lose connectivity despite trying everything other than a complete new install. All the drivers etc have been updated on the PC except the mainboard (which Fujitsu in their wisdom no longer support) and I've tried new USB wifi and Cat-6 adapters (which I happen to have spare at the moment) to no avail. Just a dead network interface. SO much so that even the system cannot "check the internet for updated drivers".

Hence my initial question, how do I stop them happening? I've tried disabling 2 services in the "Services" app, those being "Windows Update" and the "Update Orchestra Service". What else needs to be done other than throw out the PC or move to linux?
 
Joined
Nov 19, 2013
Messages
5,473
Reaction score
1,121
I cannot advise on the stopping of updates, I'm afraid.
But to persist with the loss of internet. Have you checked in the Power options and made sure you do not have the adapters in power saving mode?and made sure you do not have the
 
Joined
Oct 26, 2016
Messages
1,960
Reaction score
579
MS has just released a new cumulative update for the Versions 1903 and 1909 that deals with problems with internet connections.
It is the KB4554364
This non-security update includes quality improvements. Key changes include:

  • Addresses an issue that might display a limited or no internet connection status in the notification area on devices that use a manual or auto-configured proxy, especially with a virtual private network (VPN). Additionally, this issue might prevent some devices from connecting to the internet using applications that use WinHTTP or WinINet.
 
Ad

Advertisements

Joined
Sep 5, 2019
Messages
64
Reaction score
27
I understand why you would want to block updates - I have them disabled on my 1903 PC. Updates that break things are of no use to anyone especially those that cause days of lost productivity. I know that you've been fighting with this for more than a week. It's not something I recommend for everyone but in your case it really is the only solution since there is no garantee that a newer update will fix your networking issues.

It should be noted that simply disabling Windows Update service is not enough as I inadvertently discovered. It behaves like a zombie service that will restart and begin downloading updates against your will. This is due to the Windows Update Medic service that monitors and will re-enable Windows Update if disabled. The Medic service itself can't be disabled by ordinary means (accessed denied).

I ended up downloading a small utility that deals with that stubborn service - Windows Update Blocker.
No more nasty surprises. You can also use the tool to re-enable Windows update and the Medic service should you want to try updating at some point in the future. Who knows? Maybe a future Windows build will have working network drivers for your system (Make sure you image your PC first!).
 
Joined
Aug 15, 2015
Messages
53
Reaction score
3
Sounds like this might be just the thing I need... Also explains why the update seems to happen randomly even when the Update services are disabled, thanks. I might try one more update (including KB4554364) then it's 'the blocker'.
 
Joined
Jan 27, 2016
Messages
793
Reaction score
78
easy way is disable Cortana, you can also disable Edge. No updates. disable OS upgrades
1.
To disable Cortana in windows 10

Press Win + R keyboard accelerator to open Run dialog box.
Type GPedit.msc and hit Enter or OK to open Local Group Policy Editor. Navigate to Local Computer Policy ->
Computer Configuration -> Administrative Templates -> Windows Components -> Search.
In the right pane, double click on policy named Allow Cortana.
Select the Disabled radio button.


Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search. If you don’t see a “Windows Search†folder, right click the Windows folder and create a new key named “Windows Searchâ€. Then right-click this newly created folder in the left pane and select
New > DWORD (32-bit) Value. Name the value AllowCortana. Double-click it and set the value to 0

REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search" /v AllowCortana /t REG_DWORD /d 0 /f

2.
Hold down the Ctrl and Alt keys and tap the delete key, then click on Task Manager.
If it says "More details" at the bottom of the Task Manager window, click on it to show more details.
Scroll down the list and look for "Microsoft Edge". If you find it in the list, right click on it and select "End task".
Now, open File Explorer and find the folder "C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe" and rename that folder to anything you wish. (I normally just append some text to it like "_remove" so I can easily re-enable Edge in the future if I desire.)

Edge should now be "disabled".

Keep in mind that Microsoft may try to re-enable Edge during a future update...


Go to: C:\Windows\SystemApps\
Open folder Microsoft.MicrosoftEdge_8wekyb3d8bbwe
Right click on MicrosoftEdge file then Properties / Security / Advanced / Click Change (next to owner) and change to your username, then click OK
Then Click Edit, then add your username and give full permissions
Rename MicrosoftEdge file to MicrosoftEdge_remove or a name of your choice
Repeat all above steps for file MicrosoftEdgeCP also
Done! Edge will not run!

3.
Windows users have two options to block the upgrade to Windows 10. First, by using the Group Policy (only available on Pro, Business and Enterprise editions).

Tap on the Windows-key, type gpedit.msc and hit enter.
Navigate to the following location: Computer Configuration > Policies > Administrative Templates > Windows Components > Windows Update
Double-click on Turn off the upgrade to the latest version of Windows through Windows Update.
Enable the policy.

To undo the change, set the policy to disabled.

If you don't have access to the Group Policy Editor, or prefer using the Registry, do the following:

Tap on the Windows-key, type regedit and hit enter.
Confirm the UAC prompt if it is displayed.
Navigate to the following key: HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate
Check if the preference DisableOSUpgrade exists.
If not, right-click on WindowsUpdate and select New > Dword (32-bit) Value.
Name it DisableOSUpgrade.
Double-click the preference.
Set its value to 1.

To undo the change, delete the key or set it to 0.

To hide the Get Windows 10 app

Microsoft reveals in a Knowledgebase article how to hide the Get Windows 10 app on older versions of Windows.

The company notes that the app is not displayed on certain systems automatically, and that users don't need to do anything in this case.

Computer joined a domain.
Computer is managed through MDM.
The computer runs: Any Enterprise version of Windows, any Windows RT version, any Windows Embedded version.

A Registry key is provided that system administrators and users can set to block the Get Windows 10 application.

Open the Registry Editor again.
Navigate to the key: HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\OSUpgrade
Right-click on OSUpgrade and select new > Dword (32-bit) Value.
Name it ReservationsAllowed.
Double-click the preference and set its value to 0.

Delete the key if you want to undo the change.

It makes sense to implement these preferences on devices running earlier versions of Windows if those devices should not be upgraded to Windows 10. Obviously, this should not be the only options and a program like GWX Control Panel or manually verifying all updates before they are installed are proper options to make sure nothing slips by.
 
Joined
Apr 24, 2018
Messages
41
Reaction score
3
"...C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe" and rename that folder to anything you wish..."

Erm... I've done that half a dozen times, and Edge keeps coming back.
 
Ad

Advertisements

Joined
Jan 27, 2016
Messages
793
Reaction score
78
disable cortana
o disable Cortana in windows 10

Press Win + R keyboard accelerator to open Run dialog box.
Type GPedit.msc and hit Enter or OK to open Local Group Policy Editor. Navigate to Local Computer Policy ->
Computer Configuration -> Administrative Templates -> Windows Components -> Search.
In the right pane, double click on policy named Allow Cortana.
Select the Disabled radio button.


Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search. If you don’t see a “Windows Search†folder, right click the Windows folder and create a new key named “Windows Searchâ€. Then right-click this newly created folder in the left pane and select
New > DWORD (32-bit) Value. Name the value AllowCortana. Double-click it and set the value to 0

REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search" /v AllowCortana /t REG_DWORD /d 0 /f
 
Joined
Aug 15, 2015
Messages
53
Reaction score
3
Johnbri...

Have tried that many times but Windows keeps reenabling this option. The Windows Update Medic service keeps an eye on this service and when it sees it has been disabled it reenables it. The Medic service will not disable, or at least I cannot disable it.



On Cortana, this isn't an issue with this update yet as I'm pretty sure it is disabled permanently or at least it is suspended permanently.

Still unable to update beyond 1903,4 or even 2004 and the many updates since. Seems to be an issue with the mainboard in the portable. Likely to get retired soon, or should I say very soon.
 
Joined
Jan 27, 2016
Messages
793
Reaction score
78
@Tim Barker
How do I stop the windows update service - PERMANENTLY?
Still unable to update beyond 1903,4 or even 2004 and the many updates since. Seems to be an issue with the mainboard in the portable. Likely to get retired soon, or should I say very soon.
seems you did what you wanted. NO UPDATES. If you want to update then you have to restore all the KILLs.
 
Ad

Advertisements

Joined
Sep 5, 2019
Messages
64
Reaction score
27
It should be noted that simply disabling Windows Update service is not enough as I inadvertently discovered. It behaves like a zombie service that will restart and begin downloading updates against your will. This is due to the Windows Update Medic service that monitors and will re-enable Windows Update if disabled. The Medic service itself can't be disabled by ordinary means (accessed denied).

I ended up downloading a small utility that deals with that stubborn service - Windows Update Blocker.
No more nasty surprises. You can also use the tool to re-enable Windows update and the Medic service should you want to try updating at some point in the future. Who knows? Maybe a future Windows build will have working network drivers for your system (Make sure you image your PC first!).
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top