How do I switch OFF Windows update - Permanently?


Ad

Advertisements

Joined
Sep 26, 2017
Messages
2,714
Reaction score
527
GPedit.msc takes me nowhere. I get a dialog box telling me that GPedit.misc cannot be found.
If you have the Home Version of WIndows 10 that is true, would need the Pro Version. Somewhere on the 'net one can find how to do it for Home.
 
Ad

Advertisements

Joined
Apr 24, 2018
Messages
55
Reaction score
3
Type GPedit.msc: Bad right out of the chute. I used upped case and lower case for gp. I get a Bing page telling me much of the same.
 
Joined
Jul 8, 2021
Messages
3
Reaction score
0
I have network issues with Windows 10 1903 and versions following (ie 1909) and wish to stop the automatic update feature, As it is every time it automatically updates I lose all network connectivity, almost completely. ie it connects to my router gets an IP address then fails to connect to the internet or any machines on my network. Roll-back to 180x and no problems.

I've tried everything bar a completely new install of the OS with the obvious issue of having to reinstall software afterwards. All in a thread on the Network area of the forum. Nothing obvious works - USB network adapters, switching off all firewalls etc.

I wish to stop this automatic feature as I am happy where it is and will be getting a new PC soonish anyway. I've tried to stop the update by disabling two services - the "Update Orchestra Service" and "Windows Update" which seem to control the search for and installation of new updates for software. Unfortunately I have found that for some reason these seem to switch themselves on at random times and I find the PC going back to updating automatically. It means that I find myself having to do a rollback at least once a week - a complete waste of time.

How do I stop the windows update service - PERMANENTLY?
DISABLE WINDOWS 10 UPDATES PERMANENTLY.


Windows Update Medic Service needs to be disabled..

TO DISABLE "Windows Update Medic Service" and windows from updating.
Type regedit, in windows search
go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WaaSMedicSvc,
right click on the WaaSMedicSvc key and then click permissions.
In the "Group or user names" list, click on "SYSTEM," then click "Deny"

"Windows Update Medic Service" will now be disabled,
Windows Update will stay PERMANENTLY disabled.


TO RE ENABLE WINDOWS UPDATE


go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WaaSMedicSvc,
right click on the WaaSMedicSvc key and then click permissions.
In the "Group or user names" list, click on "SYSTEM," then click "Allow".
 
Joined
Jul 8, 2021
Messages
3
Reaction score
0
I have network issues with Windows 10 1903 and versions following (ie 1909) and wish to stop the automatic update feature, As it is every time it automatically updates I lose all network connectivity, almost completely. ie it connects to my router gets an IP address then fails to connect to the internet or any machines on my network. Roll-back to 180x and no problems.

I've tried everything bar a completely new install of the OS with the obvious issue of having to reinstall software afterwards. All in a thread on the Network area of the forum. Nothing obvious works - USB network adapters, switching off all firewalls etc.

I wish to stop this automatic feature as I am happy where it is and will be getting a new PC soonish anyway. I've tried to stop the update by disabling two services - the "Update Orchestra Service" and "Windows Update" which seem to control the search for and installation of new updates for software. Unfortunately I have found that for some reason these seem to switch themselves on at random times and I find the PC going back to updating automatically. It means that I find myself having to do a rollback at least once a week - a complete waste of time.

How do I stop the windows update service - PERMANENTLY?
Windows Update Medic Service. needs to be disabled.


Typre regedit, in windows seach box, and go to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WaaSMedicSvc, right click on the WaaSMedicSvc key and then click permissions. In the "Group or user names" list, click on "SYSTEM," then click "DENY"

Reboot Computer.

Windows Update Medic Service will now be disabled and windows update will Permanently be disabled.


TO RE ENABLE WINDOWS UPDATES and Windows Update Medic Service

go to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WaaSMedicSvc, right click on the WaaSMedicSvc key and then click permissions. In the "Group or user names" list, click on "SYSTEM," then click "ALLOW"

Reboot Computer.

Cheers.
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
5,829
Reaction score
1,199
As Snuffy says (Post #19). The OP seems to be contradicting his own posts here. He is no longer getting updates, (his last
post), which is what he requested!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top