Mouse drama


Joined
Aug 6, 2015
Messages
6
Reaction score
1
Hardware
Using a Hero G502 mouse with a Logitech G19 keyboard running LGS_9.02.65_x64 software, also use a 2nd USB keyboard a Thumb keyboard "koolertron" Smkd92 for all gaming, the USB into the keyboard is twitchy, has been this way for awhile yet the mouse dramas are new.
(G19 keyboard for the LCD screen, general typing)

System is a 2018 new built, lean clean mean gaming machine i7 8086 limited edition GTX 1080 ti with nano drives and water cooled, the bios is up-to-date as are all drivers ROG forums/Asus website. In short it's not the Box this I'm sure of.

Additional information
Problems only started appearing around end of August early September after the buggy Win update, prior to that was smooth sailing, so re-install an image from the early August. I believe that image was running the older LGS_9.00.42_x64_Logitech software Last Update: 2018-05-10 and disable Win Update, that did not fix the problem, The LGS has updated to the newer LGS_9.02.65_x64

Has anyone had issues with the LGS_9.02.65_x64 software?

There seems to be ongoing inputs with the mouse clicks. Ive uninstalled everything using Revo uninstaller related to mouse keyboard, cleaned reg entries and reinstalled the LGS_9.02.65_x64 software, this had no effect.

If on a blank area of the Desktop I click everyone button, control of the mouse and all the function below return to normal but this never last for long.

Anyone else had mouse dramas in the last month or so?

Reluctant reverting back to the older LGS_9.00.42_x64 ( like to keep up-to-date) and disabling the LGS update not so simple I suspect, so posted first to see if others are having similar problems with mouse inputs, before trying to revert back to LGS_9.00.42_x64 which seems my only choice, unless someone knows what is causing the mouse drama?

THE ISSUES:
If I single click on the title bar of a window ( like notepad) to move it, the window immediately resize to maximum
( all setting that control maximizing windows are set correctly as in Off, 'snap')

Copying wont highlight and is a very light grey when it does, misses words/skips

Takes numerous clicks to place a cursor in a dialog box

If I left click on something highlight to perform another action ( like right click delete) the object/link/file is immediately selected/activated
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top