Poor connectivity on wifi adapter after Win 10 update


Joined
Dec 12, 2015
Messages
7
Reaction score
0
I have had this HP TouchSmart for about 3 years. This is the second time this has happened Each time was after a Windows 10 update. The problem is this: after booting up, the wifi adapter sees only very near networks. I can get 2 rooms away and it doesn't even see my network, or the signal will be so weak, that it cannot connect.
But I found either of 2 workarounds. I can do a restart, in which the system does more housekeeping because the boot-up takes a good bit longer. Or, I can disable the wifi adapter for about 12-15 seconds, then re-enable it. After using either method, the adapter will see most of the networks in my neighborhood. This tells me that a normal boot does not do all the housekeeping that it should. Too many shortcuts.
Several months after the first occurrence, Microsoft finally released an update that fixed the problem. How long do I have to wait for the fix this time. It has been 1 1/2- 2 months since this occurrence started. I am using an Ralink RT3290 adapter.
 
Ad

Advertisements

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
13,417
Reaction score
2,320
Since a restart seems to fix the issue, perhaps it is linked to "fast startup"
Try disabling it and see if that helps.
Control Panel\All Control Panel Items\Power Options
Left column "Choose what the power buttons do"
Click the link near the top to "Change settings that are currently unavailable"
Untick the box next to "Turn on fast startup (Recommended)"
Click "Save changes" button

Capture1.PNG


Test with a full shut down and restart (cold boot).
 
Ad

Advertisements

Joined
Dec 12, 2015
Messages
7
Reaction score
0
Since a restart seems to fix the issue, perhaps it is linked to "fast startup"
Try disabling it and see if that helps.
Control Panel\All Control Panel Items\Power Options
Left column "Choose what the power buttons do"
Click the link near the top to "Change settings that are currently unavailable"
Untick the box next to "Turn on fast startup (Recommended)"
Click "Save changes" button

View attachment 8694

Test with a full shut down and restart (cold boot).

That works, but it is just a work-around. It seems to take forever now. The problem started with a Windows update, so I would expect a follow-up update to correct the problem. I find it faster if I just do my work-around of disabling/re-enabling the wifi adapter. I do expect MS to correct the problem since they caused it.
 
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top