SOLVED Safely Remove Hardware Icon


Joined
Dec 3, 2015
Messages
8
Reaction score
0
Subject icon is missing. It is NOT hidden. I did R-clk on taskbar, then taskbar settings, then notification area, and select icons to appear on taskbar. Unfortunately the safely remove hardware icon is not listed. I've googled and tried a couple other things to no avail. Hope I can get some help. Thank you.
 
Joined
Oct 12, 2015
Messages
142
Reaction score
21
Do you have a usb drive plugged in? If you do, does it show up in File Explorer. If not, open disk management and see if it shows up there. (Right click Start, Left click Disk Management). The icon only displays in the task bar when turned on in Settings>Personalization>Taskbar, and a drive is plugged into a usb port. If the flash drive is malfunctioning, the icon usually won't display.
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
4,248
Reaction score
823
Click the small UP arrow on the right side of the task bar. There it is.

Not 100% sure, but I dont think it is in the settings?
 
Joined
Dec 3, 2015
Messages
8
Reaction score
0
Do you have a usb drive plugged in? If you do, does it show up in File Explorer. If not, open disk management and see if it shows up there. (Right click Start, Left click Disk Management). The icon only displays in the task bar when turned on in Settings>Personalization>Taskbar, and a drive is plugged into a usb port. If the flash drive is malfunctioning, the icon usually won't display.
Hello - I have a flash drive and a WD Passport external drive connected via USB. Both show up in file explorer and under disk management.
 
Joined
Dec 3, 2015
Messages
8
Reaction score
0
Hello - I have a flash drive and a WD Passport external drive connected via USB. Both show up in file explorer and under disk management.
Click the small UP arrow on the right side of the task bar. There it is.

Not 100% sure, but I dont think it is in the settings?
Click the small UP arrow on the right side of the task bar. There it is.

Not 100% sure, but I dont think it is in the settings?
Hi Dave - that's the first place I checked since the icon is usually "hidden" - today it' not there. Thank you
 
Joined
Nov 6, 2017
Messages
196
Reaction score
31
Subject icon is missing. It is NOT hidden. I did R-clk on taskbar, then taskbar settings, then notification area, and select icons to appear on taskbar. Unfortunately the safely remove hardware icon is not listed. I've googled and tried a couple other things to no avail. Hope I can get some help. Thank you.
The "Safely remove hardware" selection is listed under Windows Explorer in Settings on my Windows 10 Home system.

Ben
 
Joined
Dec 3, 2015
Messages
8
Reaction score
0
Have you tried my post?
Hi Dave - yes I clicked the UP arrow on right side of taskbar before I posted my request for help. In fact I always have to do that because the icon is usually hidden but today it has disappeared. Thank you.
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
4,248
Reaction score
823
I think you may have the "Quick removal" policy turned on.
In the "File Explorer", Right click a usb device - Properties and, in the Next window, click a usb device and , again, properties.
Now, at the bottom, "Change settings" - Policies.
You will probably find that it is set on "Quick removal". In essence, this means that you have no need to wait for the prompt.¨, as nothing is being cached to your usb device.
If you decide to change the status, then the requested icon should appear.
 
Joined
Dec 3, 2015
Messages
8
Reaction score
0
I think you may have the "Quick removal" policy turned on.
In the "File Explorer", Right click a usb device - Properties and, in the Next window, click a usb device and , again, properties.
Now, at the bottom, "Change settings" - Policies.
You will probably find that it is set on "Quick removal". In essence, this means that you have no need to wait for the prompt.¨, as nothing is being cached to your usb device.
If you decide to change the status, then the requested icon should appear.
Hi again - you are correct it was set on "Quick removal." Odd since the "safely remove" icon has always been available to me. Should I change this to the other option "Better Performance" that will require using the safe removal tool or leave it as is? Thank you again
 
Joined
Nov 19, 2013
Messages
4,248
Reaction score
823
Well, I can only say, I have always had mine on Quick removal and never had any USB problems. One small point, of course, if you are actually doing something on a usb, and forget that, and then pull it, it could spoil the data.- Personal thought and care needed!
 

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
12,045
Reaction score
1,913
Unfortunately the safely remove hardware icon is not listed.
IF this option is not present
Capture.PNG


It could be due to a registry setting
For safe eject notification missing:
• Press keyboard "win + R"
• Type "regedit"
• Search the value "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Notifications\Settings\Microsoft.Explorer.Notification.{...}"
• If you REG_DWORD 0x00000001(0) set "0" you can double click on value. Set the value data to "1"
• Click "OK"
SOURCE: https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/icon-for-safely-remove-device-is-missing-on-system/e2c13333-4eb1-478f-8dda-451d74d56503

NOTE: That particular key is not present by default in a normal install of Windows 10, so....
IF it is not present then you can pretty much disregard this post.
 
Joined
Dec 3, 2015
Messages
8
Reaction score
0
Well, I can only say, I have always had mine on Quick removal and never had any USB problems. One small point, of course, if you are actually doing something on a usb, and forget that, and then pull it, it could spoil the data.- Personal thought and care needed!
Thanks very much Dave. I'll just leave it on quick removal. Appreciate your help very much. Happy Thanksgiving!
 
Joined
Nov 19, 2013
Messages
4,248
Reaction score
823
Tks. But, one last word. The problem has been solved. However, troubles post is the simpler way - I wasn't aware of it.
The path was - Settings - Personalisation.
Scroll down, on the left, to the taskbar and select.
Over on the right, scroll down to "Select which icons appear on the taskbar"
There is Trouble's picture - Click the Windows explorer and keep you eye open on the right of the taskbar. You will see the icon popup.
 
Ad

Advertisements

Joined
Dec 3, 2015
Messages
8
Reaction score
0
Tks. But, one last word. The problem has been solved. However, troubles post is the simpler way - I wasn't aware of it.
The path was - Settings - Personalisation.
Scroll down, on the left, to the taskbar and select.
Over on the right, scroll down to "Select which icons appear on the taskbar"
There is Trouble's picture - Click the Windows explorer and keep you eye open on the right of the taskbar. You will see the icon popup.
Thank you again. Oh my, I had been there before asking for help but was looking for the term "safely remove hardware etc" - never looked at Windows Explorer. However, I did add the icon to my taskbar using this method just in case! Your help is appreciated.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top