Trying to find correct drivers for video and audio


Joined
Aug 1, 2015
Messages
6
Reaction score
1
I upgraded an older HP Pavilion dv6910us laptop from Windows 8.1 to Windows 10 yesterday and while the upgrade went smoothly, after I logged in I found that the video was using a driver of Microsoft Basic Display Adapter and the sound was using Conexant High Definition SmartAudio 221.

The video resolution is now only 1024 x 768. I've tried to find an update but no luck so far. I've removed the video device including driver, rebooted but that just reinstalled the same driver. I downloaded the latest driver from NVidia which is supposed to work with the GeForce 630M which is what this laptop comes with but the install failed saying it couldn't find compatible hardware. I've tried WU 3 times but it's found nothing.

The audio seems like it should work but I get no sound whatsoever. In the sound properties there are choices of Speakers and SPDIF Interface. When I play an mp3 or YouTube video the SPDIF shows activity but no sound. The Speakers element shows no activity. I plugged in a set of headphones but get nothing there either. I've also tried uninstalling and reinstalling but nothing. And yes nothing is muted and the volume is almost all the way up.

Anyone have any idea of other things to try? I've tried searching for Windows 8 drivers for both but no luck. They both worked when I installed Windows 8 on it so there must be drivers for 8 but I can't find those by searching either so must have been built into 8.

Jonathan
 
Ad

Advertisements

Joined
Jul 30, 2015
Messages
8
Reaction score
4
Yes, looks like windows Update has driver for Windows 8.1
Here you can find it in Microsoft Update Catalog... use Internet Explorer, you'll have to install some extension
http://catalog.update.microsoft.com/v7/site/Search.aspx?q=GeForce 630M
nVidia - Graphics Adapter WDDM1.3 - NVIDIA GeForce GT 630M Windows 8.1 Drivers,Windows Next Graphics Driver Dynamic update Drivers (Other Hardware) 11/5/2013 1.3.26.4 234.1 MB 245454483

Give it a try - it should install without problem.
 
Joined
Aug 1, 2015
Messages
6
Reaction score
1
Thanks for the link but it turns out that's not the right driver but I didn't supply the right info either. It's a GeForce 7150m/nForce 630m. I searched the catalog for that and found drivers for Vista and 7 and downloaded the 7 driver. I tried installing it straight, in 7 compat mode and Vista compat mode and every time it said it couldn't find compatible hardware.
So I'm still stumped. If I could find the 8.1 driver I had used perhaps I could get that to work but I don't know where I got it from. I'm thinking I got it from WU but can't recall.
 
Joined
Jul 31, 2015
Messages
4
Reaction score
0
I have the same problem with Nvidia GeForce 6150, there are no drivers for Win10, I was told the latest drivers for Win8.1 would work but video and graphics just stutter and break up making viewing impossible in video format and very frustrating to view images.
 
Joined
Aug 1, 2015
Messages
6
Reaction score
1
Thanks for the link but it turns out that's not the right driver but I didn't supply the right info either. It's a GeForce 7150m/nForce 630m. I searched the catalog for that and found drivers for Vista and 7 and downloaded the 7 driver. I tried installing it straight, in 7 compat mode and Vista compat mode and every time it said it couldn't find compatible hardware.
So I'm still stumped. If I could find the 8.1 driver I had used perhaps I could get that to work but I don't know where I got it from. I'm thinking I got it from WU but can't recall.
I found a thread where a person had the same model and problem as me and one person provided a link to a Vista driver and it worked for him so I tried it and it worked for me so now I have video and audio on the laptop.
 
Ad

Advertisements

Joined
Aug 1, 2015
Messages
6
Reaction score
1
I have the same problem with Nvidia GeForce 6150, there are no drivers for Win10, I was told the latest drivers for Win8.1 would work but video and graphics just stutter and break up making viewing impossible in video format and very frustrating to view images.
Try an older version rather than the latest one and see if it works for you. Also try installing in compatibility mode.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top