Win10 Shutdown problems again


Joined
Sep 8, 2017
Messages
2
Reaction score
0
Hi anyone
When Win 8 went to win10 I had shutdown problems, I think I switched off the auto restart feature to cure it. All was working fine until I instlled the latest Win update. Guess what? Yep, laptop (HP) will not shut down. It auto restarts all the time. Tried to switch off the autorestart but no joy. So uninstalled or reverted to original win10, all ok. From what I saw of this update it was only to fix the Edge browser (which I do not use) And the updates are dubious as to any use anyway. Does anyone know how to fix this restarting problem? Dont you hate this when a company puts out an update and causes problems? No wonder Apple is growing.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,130
Hi Briana,

Do you have any external devices attached to your laptop when you are shutting down?

Some external devices [ in particular Data cards ] have been known to conflict with the PowerDownAfterShutdown process.


If you do have any external devices, disconnect one at a time and attempt shutting down, to isolate which (if any of them) is the problematic device.

If one of those devices is the cause, then you'll need to consult the Device's manufacturer website to see whether they have provided support drivers to address the issue [ as this is a problem that has been around ever since Windows 10 was released ].


If you've come across any online videos or websites recommending you adjust the <String> value: PowerdownAfterShutdown located at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon, ignore this advice as this particular Registry entry while still present is only relevant to Windows OS versions pre Windows 2000. Microsoft chose to leave this <String> value behind in the Windows Registry, but in effect its a deprecated value now. This particular value was used to send instructions to a legacy BIOS which made use of the %systemroot% hal.dll assembly file, something that most modern computers have no use for any longer.

Having said that if your laptop is fairly old [ e.g. originally had Windows 7 on it ] and is using Hal.dll then running a System File Check may find an issue with this assembly file, and repair it for you. I'd be surprised though is that were your issue.

A couple of things you could consider exploring:
  1. Right-click on Start and select Device Manager
  2. Expand your Network Adapters and check whether there are any driver updates [ or given it works if you roll back your OS, you could also consider rolling back the device driver ]
  • Something else worth trying is adjusting the HiberBootEnabled <REG_DWORD> value:
    • Press your windows key +S together to give focus to your search field
    • In the search field type command
    • In the search results right-click on Command Prompt and select Run as administrator
    • Click Yes to the User Account Control prompt
    • In the Administrator: Command Prompt console type or copy & paste the following:
Code:
REG QUERY "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power" /v HiberbootEnabled

Press Enter key

This will produce a result like the following:

rq1.png


If the value is displaying 0x1 then try the following by typing or copy & pasting the following into Administrator: Command Prompt console:

Code:
REG ADD "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power" /v HiberbootEnabled /t REG_DWORD /d 0 /f

Sample image
rq2.png


If you see that the operation completely successfully, close all open consoles and programs, then:

First: Choose to restart your laptop to allow changes to be loaded, then
Second: Attempt a full shutdown to test whether this modification helps or not.

If it makes not difference then by returning to an Administrator: Command Prompt console typing or copy & pasting the following will reverse the change you made a moment ago:

Code:
REG ADD "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power" /v HiberbootEnabled /t REG_DWORD /d 1 /f

Press Enter key

This will restore the setting back to 1


The next time you restart computer the change will take affect.

 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top