Windows 10 Firewall blocks public internet access


Joined
Dec 3, 2016
Messages
3
Reaction score
0
No problems at home, but whenever I access wifi in a public venue that requires a log-in through a website, my internet displays the message "connected, no internet". I finally tried turning off windows firewall--problem solved.

I had this problem a bunch of times but was defeated by it. Until finally, windows firewall/windows defender caused other problems, and I realized they may be the culprit here as well. My question is, does anyone know what the specific problem is? Rather than turning off the firewall entirely, I'd like to just modify a setting so that I can still be protected. I can't imagine I'm the only one who has run into this, but my Google searches have come up empty. Thanks!
 
Joined
Dec 3, 2016
Messages
3
Reaction score
0
Actually, as long as I turn it off, then login through the webpage, I can turn the firewall back on and I stay connected. So maybe I'll just do this every time I want to connect to the internet in public. Geez.
 
Ad

Advertisements

Joined
Jul 26, 2015
Messages
41
Reaction score
3
Hi Mickey. Not sure, but this might work. Go to Control Panel and the Windows Firewall. This is where you are probably turning the firewall on and off at, when you click on "Turn Windows Firewall on or off." Where it says "Public network Settings", uncheck "Block all incoming connections, including those in the list of allowed apps." .... Might work, hope it does. Cheers.
 
Joined
Dec 3, 2016
Messages
3
Reaction score
0
Hi Mickey. Not sure, but this might work. Go to Control Panel and the Windows Firewall. This is where you are probably turning the firewall on and off at, when you click on "Turn Windows Firewall on or off." Where it says "Public network Settings", uncheck "Block all incoming connections, including those in the list of allowed apps." .... Might work, hope it does. Cheers.
Thanks for the reply, Acer! I already had that box unchecked. So that was not the factor. Still not sure what the problem is :/ But turning the firewall off and then back on is a doable workaround.

On a different note, I am trying to create a Wordpress website hosted on AWS, and I'm trying to use PuTTY to SSH into my instance. I'm getting an error message. Google searches suggest that this problem is also caused by Windows 10 :( Feeling some buyer's remorse for not getting a new MacBook instead.
 
Joined
Jul 26, 2015
Messages
41
Reaction score
3
Hi Mikey .. sorry that your issue has not been solved yet. I'm only a basic kinda computer person, and I have no idea what you are talking about when it comes AWS, PuTTY and SSH !! Never mind, there is always light at the end of the tunnel. It seems Windows 10 is always not very happy with so many other applications and situations. Hope it all works out. TC. Cheers.
 
Ad

Advertisements

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
12,051
Reaction score
1,913
You may want to consider using the Firewall applet in the Control Panel to "Allow an app or feature through Windows Firewall" left column.
Then use the "Change settings" button and possibly the "Allow another app...." button to support what you are trying to do.
Although I wouldn't be too quick to do so in a public environment, you should see that both "Private" and "Public" networks can be addressed.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top