Windows 10 updates automatically


Joined
Mar 25, 2016
Messages
2
Reaction score
0
Greetings!
Like in the title Windows updates automatically and I can't reschedule updates. When I go to Settings > Update & Security > Windows Update, the option to set time of the next reboot is bright grey and I can't switch to it. I've changed option in advanced settings to Notify to schedule restart but PC keeps rebooting without my permission. Please help.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,133
Hi,
  1. Which version of Windows 10 are you using?
  2. Are you using a 32-bit or 64-bit OS?

As well as answering the above two questions do the following:
  • Press Winkey + X key | select Command Prompt (Admin)
  • Type or copy & paste the following command then press ENTER key
    • reg query hklm\software\policies\Microsoft\windows\windowsupdate\au > %userprofile%\desktop\windowsupdate.txt
  • Type exit | press ENTER key to close Command window
  • Now when replying to the above questions also click the "Upload a file" button and attach the windowsupdate.txt file you just created and saved to your Desktop

Regards,

Regedit32
 
Joined
Mar 25, 2016
Messages
2
Reaction score
0
Hi,
  1. Which version of Windows 10 are you using?
  2. Are you using a 32-bit or 64-bit OS?

As well as answering the above two questions do the following:
  • Press Winkey + X key | select Command Prompt (Admin)
  • Type or copy & paste the following command then press ENTER key
    • reg query hklm\software\policies\Microsoft\windows\windowsupdate\au > %userprofile%\desktop\windowsupdate.txt
  • Type exit | press ENTER key to close Command window
  • Now when replying to the above questions also click the "Upload a file" button and attach the windowsupdate.txt file you just created and saved to your Desktop

Regards,

Regedit32
I'm using Windows 10 Pro 64 bit
After copying the line this appeared: ERROR: The system was unable to find the specified registry key or value.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,133
That is unusual, as the Pro 64-bit version ought to contain two registry keys in relation to Windows Update.

There are two methods you could consider at this point:
  • Using the Group Policy Editor to adjust the settings
  • Merging some new keys into the Registry with correct DWORD values

Happy to explain how to use the Group Policy Editor, but for now let's try the simpler merge option:
  • Open a Notepad file and copy the following five lines of instruction into it:
Registry Editor Version 5

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"AUOptions"=dword:00000002

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies\Microsoft\Windows\WindowsUpdate\AU]
"AUOptions"=dword:00000002

That DWORD AU Options has four settings:
  • 2 (To notify for download and notify for install)
  • 3 (To auto download and notify for install)
  • 4 (To auto download and schedule the install)
  • 5 (To allow local admin to choose setting)
If you prefer 3, 4 or 5 as the option then in the Notepad change both "AUOptions". For example if you wanted option 5 then change like so: "AUOptions"-dword:00000005

  • Now in Notepad click File | Save As
  • In the left pane select Desktop as location to save to
  • Next to "File name" type update.reg
  • Next to "Save as type" use the drop arrow to choose All files
  • Click the Save button
  • Next go to desktop and right click on the update.reg file you just created | select Merge
    • An alert will pop up click yes
    • Another alert will pop up click yes
    • Finally click OK
  • Reboot computer for changes to take affect.

Let me know if the issue is resolved. If not I'll explain the Group Policy Editor and how to make changes there.

Regards,

Regedit32
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top