Windows laptop continually changing to incorrect time

Feb 8, 2024
Reaction score
Ok, so I have a major issue on my Windows 11 laptop (Lenovo IdeaPad 5 approx. 3.5 years old) that's been driving me nuts for months now and it's time to finally get it sorted. The problem is that my laptop keeps losing time i.e. throughout the day the clock will show an incorrect time, initially losing 5 or 10 minutes and then by the end of the day it will be 2 to 3 hours behind the correct time. I am constantly right-clicking the clock and selecting "Adjust date and time" then "Sync now", which syncs the clock to the correct time from server, but before long it starts losing time again. The annoying thing is that I have "Set the time zone automatically" and "Set the time automatically" set to true, and the Time server is set to "". I also tried "" but it didn't fix the problem.

There are a lot of posts online that have this issue and most of the answers are either set the time to update automatically (which I do), check the CMOS battery (it's fine), and right click and manually update the time. Also to run chkdsk and / or the Dism /Online command with various options and then restart etc. I've spent many hours trawling the web and reading various posts with the same issue but none of the answers have worked for me. Things I've tried:

- Checked the option to set the time automatically, also unchecked it.
- chkdsk and all the Dism /Online commands
- Synced with different time servers i.e. and
- Checked if the CMOS battery is good (it is).
- Booted into the UEFI setup and set the time there (this worked for a bit after the restart but after a couple of hours the clock started losing time again).
- Manually started the Windows Time services in services.msc and changed the startup type to Automatic from Manual (it always gets set back to Manual though)
- net stop w32time -> w32tm /unregister -> w32tm /register -> net start w32time

Here are details of my laptop:

Device Spec:
Processor AMD Ryzen 7 4800U with Radeon Graphics 1.80 GHz
Installed RAM 16.0 GB (15.4 GB usable)
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Windows Spec:
Edition Windows 11 Home
Version 23H2
Installed on 03/02/2024
OS build 22631.3085

Here are some recent entries from the Event Viewer System log relating to the time service:

Information 04/02/2024 15:28:02 Kernel-General 1 (5)
The system time has changed to 2024-02-04T15:28:02.500000000Z from 2024-02-04T16:16:18.958887700Z.
Time Delta: -2896458 ms
Change Reason: System time synchronized with the hardware clock.
Process: '' (PID 4).
RTC time: 2024-02-04T15:28:02.500000000Z
Current time zone bias: 0
RTC time is in UTC: true
System time was based on RTC time: false

Information 04/02/2024 15:52:09 Time-Service 158 None
The time provider 'VMICTimeProvider' has indicated that the current hardware and operating environment is not supported and has stopped. This behavior is expected for VMICTimeProvider on non-HyperV-guest environments. This may be the expected behavior for the current provider in the current operating environment as well.

Information 04/02/2024 15:52:11 Time-Service 37 None
The time provider NtpClient is currently receiving valid time data from,0x9 (ntp.m|0x9|>
So I can see the issue happens with the "Change Reason: System time synchronized with the hardware clock" entry in the Event Viewer, but I don't know why the system is synchronizing with a hardware clock when I already have it syncing with an online time server?

If anyone has any suggestions I'd be really grateful. I read another post that a person had this issue and even re-installing Windows didn't fix it. Soon I'll have to consider buying a new laptop, can't go on like this :-/

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question