SOLVED All PDF files changed to Avast HTML Documents

Joined
Dec 11, 2017
Messages
1
Reaction score
0
All of a sudden all my saved PDF files in Windows 10 have been change to Avast HTML.Document - As well as when I scan files to .pdf on a usb stick they show up as Avast HTML Documents... very frustrating and haven't found a solution, hopefully until now, on here :)
 
Last edited by a moderator:
Joined
Feb 18, 2016
Messages
2,835
Reaction score
631
Can right click on a file and select "Open with" the default viewer.
Or open settings > Default Apps > Choose default apps by file type.
 
Joined
Jun 10, 2018
Messages
1
Reaction score
2
All of a sudden all my saved PDF files in Windows 10 have been change to Avast HTML.Document - As well as when I scan files to .pdf on a usb stick they show up as Avast HTML Documents... very frustrating and haven't found a solution, hopefully until now, on here :)

You may already have figured this out. But I just got a laptop with Windows 10, and the same thing happened to me. I fixed the problem by doing the following:

1. Right-click on any Avast HTML document
2. Select "Properties" at the bottom of the drop-down menu
3. When the window pops up, it should be on the "General" tab view
4. In this pop-up window, look for "Opens with:", and you'll see the program currently associated with the file (in this case "Avast HTML Document"); next to this will be a "Change" button
5. Click on the "Change" button. When another window pops up asking "How do you want to open [current program] files from now on?", click on "More apps" under OTHER OPTIONS and select Adobe Acrobat.
6. Click OK,
7. Exit.

You should be all set. Note: If the "Change" button is grayed out, then that's another issue, and unfortunately I don't know how to work around that.
 
Joined
May 6, 2019
Messages
3
Reaction score
0
You may already have figured this out. But I just got a laptop with Windows 10, and the same thing happened to me. I fixed the problem by doing the following:

1. Right-click on any Avast HTML document
2. Select "Properties" at the bottom of the drop-down menu
3. When the window pops up, it should be on the "General" tab view
4. In this pop-up window, look for "Opens with:", and you'll see the program currently associated with the file (in this case "Avast HTML Document"); next to this will be a "Change" button
5. Click on the "Change" button. When another window pops up asking "How do you want to open [current program] files from now on?", click on "More apps" under OTHER OPTIONS and select Adobe Acrobat.
6. Click OK,
7. Exit.

You should be all set. Note: If the "Change" button is grayed out, then that's another issue, and unfortunately I don't know how to work around that.


Well, I have hundreds of Adobe PDF files. I think it is Avast, rather than Window 10, that changes them. ALL my files are now Avast HTML files. I don't want to have to change them all one at a time. Can I fix all of them somehow quickly? Also, how can I keep Avast from doing this again? I was chatting with Avast and got dropped, so I don't think I can count on Avast to help.
 
Joined
May 6, 2019
Messages
3
Reaction score
0
Well, I have hundreds of Adobe PDF files. I think it is Avast, rather than Window 10, that changes them. ALL my files are now Avast HTML files. I don't want to have to change them all one at a time. Can I fix all of them somehow quickly? Also, how can I keep Avast from doing this again? I was chatting with Avast and got dropped, so I don't think I can count on Avast to help.
So, I changed one file back to Adobe PDF and miraculously all the file that had been changed to Avast HTML changed back! Hooray!
 
Joined
Aug 6, 2019
Messages
1
Reaction score
0
All of a sudden all my saved PDF files in Windows 10 have been change to Avast HTML.Document - As well as when I scan files to .pdf on a usb stick they show up as Avast HTML Documents... very frustrating and haven't found a solution, hopefully until now, on here :)
Hi Ken, I had the same problem. I have the free, basic-level, Avast antivirus service and must have pressed an option that converted access to files only through the Avast secure browser. After which so many docs and files changed to HTML documents. I rang the Avast tech helpline on 0800 085 4825 today and they reversed the action and restored all my files and docs to Word.
 
Joined
May 6, 2019
Messages
3
Reaction score
0
All of a sudden all my saved PDF files in Windows 10 have been change to Avast HTML.Document - As well as when I scan files to .pdf on a usb stick they show up as Avast HTML Documents... very frustrating and haven't found a solution, hopefully until now, on here :)
I had the same problem awhile back. All I had to do was save as one of the Avast files as an Adobe .pdf. All of the Avast file turned back into Adobe files when I did that. I haven't had a problem since. Try it. If it asks you any questions about setting Adobe as the devault, say "yes."
 
Joined
Aug 10, 2019
Messages
2
Reaction score
0
You may already have figured this out. But I just got a laptop with Windows 10, and the same thing happened to me. I fixed the problem by doing the following:

1. Right-click on any Avast HTML document
2. Select "Properties" at the bottom of the drop-down menu
3. When the window pops up, it should be on the "General" tab view
4. In this pop-up window, look for "Opens with:", and you'll see the program currently associated with the file (in this case "Avast HTML Document"); next to this will be a "Change" button
5. Click on the "Change" button. When another window pops up asking "How do you want to open [current program] files from now on?", click on "More apps" under OTHER OPTIONS and select Adobe Acrobat.
6. Click OK,
7. Exit.

You should be all set. Note: If the "Change" button is grayed out, then that's another issue, and unfortunately I don't know how to work around that.
Thanks... simple and to the point.
 
Joined
Sep 4, 2019
Messages
1
Reaction score
0
You may already have figured this out. But I just got a laptop with Windows 10, and the same thing happened to me. I fixed the problem by doing the following:

1. Right-click on any Avast HTML document
2. Select "Properties" at the bottom of the drop-down menu
3. When the window pops up, it should be on the "General" tab view
4. In this pop-up window, look for "Opens with:", and you'll see the program currently associated with the file (in this case "Avast HTML Document"); next to this will be a "Change" button
5. Click on the "Change" button. When another window pops up asking "How do you want to open [current program] files from now on?", click on "More apps" under OTHER OPTIONS and select Adobe Acrobat.
6. Click OK,
7. Exit.

You should be all set. Note: If the "Change" button is grayed out, then that's another issue, and unfortunately I don't know how to work around that.
Thank you so much! This worked. I'm so relieved.
 
Joined
Oct 13, 2022
Messages
1
Reaction score
0
You may already have figured this out. But I just got a laptop with Windows 10, and the same thing happened to me. I fixed the problem by doing the following:

1. Right-click on any Avast HTML document
2. Select "Properties" at the bottom of the drop-down menu
3. When the window pops up, it should be on the "General" tab view
4. In this pop-up window, look for "Opens with:", and you'll see the program currently associated with the file (in this case "Avast HTML Document"); next to this will be a "Change" button
5. Click on the "Change" button. When another window pops up asking "How do you want to open [current program] files from now on?", click on "More apps" under OTHER OPTIONS and select Adobe Acrobat.
6. Click OK,
7. Exit.

You should be all set. Note: If the "Change" button is grayed out, then that's another issue, and unfortunately I don't know how to work around that.
Thank you so much, problem solved !!
 
Joined
Apr 27, 2023
Messages
1
Reaction score
0
All of a sudden all my saved PDF files in Windows 10 have been change to Avast HTML.Document - As well as when I scan files to .pdf on a usb stick they show up as Avast HTML Documents... very frustrating and haven't found a solution, hopefully until now, on here :)
OK, out of the mouth of babes.....female friend queried, surely you have Adobe Acrobat. I responded when the fix didn't work..Oddly it has disappeared. She smiled and said, reinstall it and choose as your go to for pdfs. I did and it worked. Awesomely and immediately. now here is the conundrum: who gave Avast the power to switch our pdfs? not happy with that. and i will be CALLING Avast to express my concern. Big brother aside, give me the power to decide who I want to handle my pdfs.
 
Joined
Sep 26, 2017
Messages
3,485
Reaction score
617
It may also be helpful to know that Internet Browsers are changing to include .pdf support so may be another place to check.
 
Joined
Jul 7, 2023
Messages
1
Reaction score
0
This is all about association between an extension and the tool which opens the file by default. The fact that a PDF file shows as AVAST is due to the windows/file explorer way of working. The file themselves are not containing this information on Windows (but they do on Mac).

So there is no magic, just an association to manage. Some tool however change that at installation time... without really notify you.
 
Joined
Sep 26, 2017
Messages
3,485
Reaction score
617
Also it's good to keep in mind a major difference between Mac and Windows in the number of programs available to open files, many more available for Windows. In one respect it's good to have more choices but in another way limited choices in Mac can give better control. Personally I prefer cross-platform programs that work nearly the same in Linux, Mac and Windows.
 
Joined
Feb 29, 2024
Messages
1
Reaction score
0
I had a different version of the problem and the solution proposed here didn't work (couldn't open the files downloaded from Avast secure browser).
My issue was that I could only download htm documents with ASB.

Here is what I did to fix:
1. Click on the 3 dots in asb.
2. Select parameters
3. Select confidentiality and security tab
4. Go to the bottom and click "additional content settings"
5. Then Select "PDF documents"
6. Select "download pdf documents " instead of " open pdf documents in avast secure browser"

It was very well hidden and I lost a lot of time trying to fix it. So maybe it will help someone else...
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top