SOLVED Another startup program problem.


Joined
Apr 7, 2018
Messages
11
Reaction score
1
I have been working for 2 days trying to get a program to launch at startup on my recent Windows 10 upgrade.. The program is Wallmaster Pro. an old program that I have used for many years. This program is an automated wallpaper changer. It runs just fine from the desktop but I cannot get it to run at startup I have tried the shortcut in the startup folder. I have tried the elevated task scheduler method. I have tried the edit the registry method. I also was unable to get this program to launch at startup in Windows 8.1. I would have given up long ago except that I have an old Gateway laptop that has been updated from Vista to 8 to 8.1 to Windows 10 and this same program has run at startup through all those upgrades of OSs and runs at startup from the startup folder on that machine in Windows 10. I have tried to duplicate the same conditions on the new machine. UAC settings are the same. Run as administrator is off on each. Compatibility mode is turned off on each . Both machines are running the latest Windows 10 with all updates installed. This is not a life or death problem but I hate to let this problem beat me. Is there a genius out there who can tell me what might be the difference?
 
Ad

Advertisements

Joined
Nov 6, 2017
Messages
238
Reaction score
35
Press the Windows and "R" keys simultaneously, type "regedit" into the "Open" box and click "OK". When regedit starts, expand the following key, find "Startup" in the right window and make sure you using that folder. You may have to use the bottom scroll bar to see the entire path.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

Ben
 
Joined
Nov 6, 2017
Messages
238
Reaction score
35
Please explain why you think you needed to try my procedure more than once.

Ben
 
Joined
Apr 7, 2018
Messages
11
Reaction score
1
Sorry I didn't read your post carefully enough. Yes I have that key in the registry, but i'm not sure how that helps me. I have the shortcut installed in C:\Users\Frank Schabel\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup\wallmaster pro.lnk. I believe that is the proper location
 
Joined
Nov 6, 2017
Messages
238
Reaction score
35
The idea is that the data in that registry key's "Startup" entry contains the path to the startup folder. There is another startup folder that autostarts programs for all users. You might try that one.

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp

Ben
 
Joined
Apr 7, 2018
Messages
11
Reaction score
1
tried that and didn't work. I'm thinking it is some problem in ownership of permissions that I haven't figured out yet. The closest I have come is writing a startup task to run the program. I had just prior tried to reinstall the program over the existing installation. When the startup task ran it said it was trying to run but couldn't find a bunch of dlls that the program needed and to reinstall the program. They were of course there but some registry entry wasn't correct.. This program is so old it's uninstall program doesn't work in windows 10.I deleted everything I could find with the name mentioned and reinstalled. The program then worked from the program.exe, from any shortcuts and the startup task when I just ran it but not at startup, no error message. Like I said in my first message, I would have given up long ago except for the fact that it runs at startup on another Windows 10 installation.
 
Ad

Advertisements

Joined
Nov 6, 2017
Messages
238
Reaction score
35
You might try right-clicking the shortcut and selecting "Troubleshoot compatibility".

Ben
 
Joined
Apr 7, 2018
Messages
11
Reaction score
1
I have tried that setting for the program and the shortcut. On the laptop where the start on boot works the program is set to emulate windows xp
That setting doesn't appear to available on Windows 10 on my main computer. The program and the run at startup worked fine when I was running Windows 7 so I don't think that is the problem.
 
Joined
Apr 7, 2018
Messages
11
Reaction score
1
I misstated. On the laptop where the programs runs on startup and works correctly the compatibility mode is set to off. I have learned a little more but not enough. I used an uninstall program to clean out everything since the built in uninstall is obsolete. I reinstalled. The setting in the program itself to run on startup installed the shortcut in the start menu. If i have the compatibility setting in the program set to emulate windows xp, then the program opens on startup but does not run correctly. If compatibility is turned off the program does not load on startup but works perfectly when run from the desktop. I have to be missing something that explains the difference between the behavior of the 2 computers but I can't figure out what.
 
Joined
Nov 6, 2017
Messages
238
Reaction score
35
Right-click the shortcut, select "Properties" and make sure the "Start in" box contains the path to the program files.

Ben
 
Ad

Advertisements

Joined
Apr 7, 2018
Messages
11
Reaction score
1
Problem solved. Set program to run in compatibility mode for XP and then created an elevated shortcut to the program and placed it in the startup folder. runs on boot and seems to be working correctly; for now.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top