SOLVED Cannot change languages when writing


Joined
Jul 22, 2015
Messages
199
Reaction score
19
Using Windows 10 on a Dell laptop.
I have downloaded and installed and set up two languages.
I have always been able to write in either of the two languages by the simple selection in the taskbar. Now there is nothing in the taskbar to allow changing.
I don't know when this occurred as I was away for awhile.
Searching for a solution proved to be futile because they all say to select the language in the taskbar.
Suggestions?
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
Hi,

To get the language icon back:
  • Click Start > Settings > Time & language
  • Next in the left pane click Region & language
  • Now in the right pane click the hyperlink Additional date, time, and regional settings
  • Next in the right pane click the hyperlinked Language
  • In the left pane click Advanced settings
  • In the window that opens, under Switching input methods place a check mark next to Use the desktop language bar when it's available
  • Just beneath this click the hyperlinked Change language bar hotkeys
  • In the Text Services and Input Languages window that pops up, click the Language Bar tab
  • Check the radio button next to Docked in the taskbar
  • Click Apply, then click OK
  • This will close the Popped up window, returning focus to Advanced settings window. Click Save.
  • Close the windows and you ought to now see EN on bottom right of taskbar next to System tray assuming of course English is your primary language setting otherwise EN will be something different.
Note: Microsoft successfully hid this option without the use of smoke, mirrors and special stage lighting. :rolleyes:

Regards,

Regedit32
 
Joined
Jul 22, 2015
Messages
199
Reaction score
19
Thank you for the excellent reply. I followed each step and can now write in both languages. However... there is no icon or symbol of any sort on my taskbar. I use Alt + Shift to change back and forth, but there is nothing to tell me which language I have currently selected. I left click the taskbar and searched for something to do with language but there is nothing available anywhere. Or at least I can't find anything. Strange, but anyway I have the two language capability and I again thank you for that.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
Hi again,

On My taskbar I see this on right end:

Language.png


That EN is the language bar icon using text

It's showing the EN because in the Text Services and Input Languages window I checked the box next to Show text labels on the Language bar like in this image below:

Language2.png


If you check the box above it too (i.e. both boxes checked) you will see the EN with a blue circle and white question mark in the circle to the right of EN. That might make it stick out more for you. By box above it I mean the one next to Show additional Language bar icons in the taskbar

Don't forget to click Apply then OK after checking the box or boxes.

I don't think you need to restart the PC, but perhaps a restart of the PC will allow the Shell32.dll to reload and trigger the Language Bar icon for you.

Regards,

Regedit32
 
Last edited:
Joined
Jul 22, 2015
Messages
199
Reaction score
19
Sorry for the late reply. Had a job to do.

Okay, I have checked both of those boxes but still no "EN". Strange, but true.
 
Joined
Nov 19, 2013
Messages
6,151
Reaction score
1,250
Just curious. Your initial post. What exactly do you mean by "write in either language". I have a Danish/international keyboard. This shows the four or five extra language symbols. I can write in either language, without any difficulty, straight from the keyboard

I wish my English was better
Jeg ønsker min engelsk var bedre
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,139
Sorry for the late reply. Had a job to do.

Okay, I have checked both of those boxes but still no "EN". Strange, but true.


That is odd.

The only other thing I can think of would be to:
  • Right-click on taskbar > select Properties
  • Then under the Taskbar tab check box next to Use small taskbar buttons
  • Just beneath those boxes are some drop arrow options.

    Next to Taskbar buttons: select Never combine
  • Click Apply when done

You should only need to do this if your taskbar is full of icons though. Which generally is not the case.
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
6,151
Reaction score
1,250
Try "Settings" - "Region and Language" - "Additional Date, Time and regional" -" Language/Add a language"
Check "Advanced settings" (over on the left)
Half way down is the option "use the desktop language bar when available"

Also. Try clicking the windows key plus space. It should give you the same options
 
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top