Can't boot after dual-boot crash (Windows 10 and Ubuntu)

Joined
Jul 4, 2018
Messages
1
Reaction score
0
have a problem with my Lenovo h500. I replaced the hard drive with a 1 TB WDC drive and upped the RAM to 8 GB.

The unit came with Windows 8, and I upgraded to Windows 10 and have installed every update up until May 2018.

Then I installed ubuntu 18.04 in a dual-boot configuration, keeping my Windows 10. A few days ago, while ubuntu was updating to a new version, my mouse ran out of power, and the machine suddenly switched off.

When I rebooted, I got a black screen with a message that lasted less than a second. By videoing the screen, I was able to get this:

Failed to open \EFI\BOOT\grubx64.efi – Not Found

Failed to load image \EFI\BOOT\grubx64.efi – Not Found

Start_image() returned Not Found

So, I can’t boot into windows or ubuntu, but I can get to a cmd prompt line using a Windows recovery DVD. My bios doesn’t help. It only gives me an option to start in UEFI or legacy mode. After failing with legacy, I’ve switched to UEFI permanently. But the BIOS won’t let me scrounge around and delete references to ubuntu. And I can’t get to it through the command line on the Rescue Disk either.

So here are the things I’ve tried to fix this:

  1. Ran the ubuntu Boot_repair program. Didn’t fix it.
  2. Tried to replace the file in terminal. Didn’t fix it.
  3. Re-installed ubuntu. Didn’t fix it. Just added another copy.
  4. Removed the new installation of ubuntu. Didn’t fix it.
  5. Deleted the partitions on which ubuntu resided. Created a new partition in that space. Didn’t fix it.
  6. Tried to fix the FAT32 system partition through a number of different means, including:
    1. Using the bootrec /fixboot command. Response: Access is denied.
    2. Tried bootrec /rebuildbcd. Access denied.
    3. Tried to open the bcd with BCDedit. OS couldn’t find the “object.”
    4. Decided I needed full access to the System Disk. Assigned a drive letter to the system disk. Didn’t fix it. Access problem not fixed.
    5. Changed the gpt attributes of the file. Access problem not fixed..
    6. Tried the Set=id 07, and 17. Those commands, though suggested in many blogs, were not recognized by Recovery disk OS. Access problem not fixed.
    7. Using DISKPART, deleted the system partition. Created a new EFI partition. Didn’t fix it. SWith a brand new system drive, still can’t use the bootrec tools. Couldn’t unhide the partition I created. Still no access to bootrec tools.
If the problem is that the BIOS is still being told to look for the ubuntu starter, then the problem appears not reside in the system disk, which although still hidden doesn't have any references to the ubuntu files. My questions are:

Why can’t I use the bootrec tools?

On which partition is this screen message stored?

How can I access what the BIOS appears to accessing, namely, a file that is telling it to try to open ubuntu?

Why is there no ubuntu uninstall program?



Thanks
 
A

Advertising

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
11,858
Reaction score
1,881
A

Advertising

Joined
Oct 1, 2014
Messages
1,873
Reaction score
261
If you have removed and replaced the EFI system partition you need to move the boot files to that partition. This assumes that when you boot into the install or recovery media, the Windows partition is still C. If not, revise accordingly and if you aren't sure use the lis vol command in Diskpart.

bcdboot C:\Windows

from the command prompt.

Then reboot and make sure the Bios is showing the Windows Boot Manager as the first priority for boot device.

I will assume when you replaced the EFI system partition you used the command below in Diskpart? Of course, this would replace the original one if no other free space was on the drive.

cre par efi

Before you removed the original EFI partition, you may have been able to just re-enable the Windows Boot Manager which is normally a different folder from the Ubuntu folder.

I rarely use Ubuntu in dual boot mode on a working system. If I did, I would be very careful so Grub did not overwrite the normal Windows boot.
 
A

Advertising

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top