SOLVED Drive letters no longer assigned automatically


Joined
Oct 26, 2016
Messages
1,921
Reaction score
563
Drive letters no longer assigned automatically

Usually, if I connect an external drive, it gets a drive letter that is next in line of availability or more, depending on how many partitions I have. For quite some time now this is no longer the case. I occasionally delete greyed out drives (volumes including the shadow volumes) from the device manager, however the automatic assignment does no longer function. For every drive I connect I have to manually assign a letter in the device manager. The weird thing is that it does not apply the flash drives, only to external SSD and other drives.

Is there something I can do about that beside resetting the OS? FYI: the OS is Windows 10 built 1803 that I need to keep on this PC for hardware reasons (and it is up-to-date).

I have yet to look in the registry which I rather not do at this moment...
 
Ad

Advertisements

Joined
Apr 22, 2017
Messages
4,358
Reaction score
569
Hi Grizzly,

try the following:

  1. Open Command Prompt as an Administrator (search for Command Prompt on the Start Menu, right click, Run as Administrator)
  2. At the Command Prompt, type ‘diskpart’ and hit Enter. Wait several seconds for the DISKPART prompt to appear.
  3. At the DISKPART prompt, type ‘automount enable’ and hit Enter.

Source: https://community.wd.com/t/windows-10-doesnt-automatically-assign-drive-letter/150625/2

I hope it helps. :)
 
Joined
Jul 29, 2015
Messages
6
Reaction score
1
Some time ago following a Windows 10 update I lost the ability to connect automatically to my Western Digital MyBookWorld network shared drive. I called Microsoft support who took remote control of my machine and the MS tech eventually decided that we needed to add a Windows feature. The tech did this by (1) opening Control Panel, (2) clicking on Programs and Features, (3) clicking on Turn Windows Features On or Off, then scrolling down to the "S's" and enabling/checking "SMB Direct" (SMB=Server Message Block). It was so long ago that it might have been one of the other SMB feature settings as well. I just can't remember. I documented this at the time, but now can't find my documentation. If trying the SMB feature doesn't work you could re-phrase your post to include a reference to "SMB" to see if that prompts some additional replies from others who might be able to help fix your issue.
 
Ad

Advertisements

Joined
Oct 26, 2016
Messages
1,921
Reaction score
563
So far Wolfie's Tip worked like a charm. Thank you for that.
Gonna mark this one solved (and I have to remember that one in case I need it again)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top