Installing Windows 10 Build 10166 on ASUS Maximus VI Formula ROG MB


Joined
Jul 10, 2015
Messages
20
Reaction score
4
Hello,

If you are thinking of installing Windows 10 Build 10166 and your MB is an ASUS Maximus VI Formula with the latest BIOS installed for you MB. After installing Windows 10 you may have a bit of a problem with no internet connection via LAN or WiFi. As soon as I seen there was a problem I immediately went into Service Desk Mode... Okay Surface Pro 3 is working so it isn't a LAN or WiFi problem with the modem nor the router. So I restarted my rig and it was still the same.

Then it hit me... I bet it's a BIOS problem. Refreshed the BIOS [O] button on the back of the MB, then turn it back on again. Del and then back into the BIOS reconfigure the settings to whatever your settings were before you refreshed the BIOS then F10 to save and restart for the last time then...? Desktop all working fine. So if you have an ASUS Maximums VI Formula MB and your connection isn't working do what I have done and it will be working again.

All the drivers work fine... but one rather bizarre thing happens. It uninstalled Norton Security for some reason as there is no sign of it anywhere on the system. I ran the Norton Removal Tool just in case. But I have never encountered that ever with an OS removing the security. Very odd indeed.
 
Last edited:
Ad

Advertisements

Joined
Jul 14, 2015
Messages
4
Reaction score
1
Hi mate i have a maximus 6 formula board also,

i will be upgrading from 8.1 to 10 when 10 comes out officially does the 8.1 drivers work perfectly on 10 ??
 
Joined
Jul 10, 2015
Messages
20
Reaction score
4
Hi mate i have a maximus 6 formula board also,

i will be upgrading from 8.1 to 10 when 10 comes out officially does the 8.1 drivers work perfectly on 10 ??
I would hold off at the moment mate. As soon as there are drivers and BIOS updates released or I here of any Beta BIOS or drivers available I will update this thread.

...Um no. According to MS Windows 10 compatibility is states that my system was fine and everything was compatible. which after upgrading* there was a lot of hardware and applications which didn't work again.

I have a Creative Soundblaster ZxR soundcard and it does not work...? (No surprise there, don't expect drivers for Windows 10 on the day of release because they are very slow at developing drivers)

After troubleshooting my system I am convinced the issue is with the BIOS cause there is no conflicts within Device Manager...? If there was then it would be a software issue as well as a BIOS issue. I'd wait until ASUS release a BIOS update. At the moment there isn't any official BIOS updates for this MB at the moment. But ASUS are normally pretty good with their BIOS updates. The last BIOS update was 9 months ago.

* I would strongly recommend that you backup everything either using a third party software or just use the file update within Windows 8 and 8.1 so that you can revert back to your previous OS.
 
Joined
Jul 10, 2015
Messages
20
Reaction score
4
I'm going to try 10240 tomorrow I need to get up for work tomorrow and I have a 45 minute drive to work so I need some shut eye. I will try this tomorrow and if it works I will let you know. Knowing ASUS as I have been a customer of theirs for well over a decade, they will most likely release a BIOS update either just before or on the day of release of Windows 10 on July 29. There isn't nothing from Creative at the moment.

I will keep you posted.

I only checked the website an hour ago and there was no updates. Windows 10 has been added to ASUS website for the following...

http://www.asus.com/us/Motherboards/MAXIMUS_VI_FORMULA/HelpDesk_Download/

As usual Creative Labs nothing at all. No surprise there then really.
 
Last edited:
Joined
Jul 10, 2015
Messages
20
Reaction score
4
Okay I have installed all the latest drivers for the motherboard... (No BIOS update as of yet, although if they do have one in the pipeline they normally release it on the day or just before the release of Windows 10). They done the same with Windows 8.

Windows 10 Drivers from ASUS for the ROG Maximums VI MB All the other software will work. If you have a Corsair liquid cooled CPU block running Corsair Link. There is a new set of drivers for CorsairLink v3.1.

Intel Bluetooth
Intel Chipset
Intel MEI
Intel LAN
Intel Wireless
Intel SATA

According to an article I read from PC World in the States. Microsoft said that it will allow their users to run a clean install of Windows 10 Pro which is great news because I hate doing upgrade because something can always go Pete Tong. That's a polite way of saying it's gone t**s up... When the upgrade is finished I will let you know if it has been successful. I'm on 10240 now which is a vast improvement over the previous build 10166. Although I think there may be some final tweaks here and there before initial release and the build it likely to change. I would put my reputation on it that 10240 isn't the final build. It's a Techie thing... :)
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top