Looking for Help


Joined
Feb 16, 2021
Messages
1
Reaction score
0
Hi, everyone

something happen to my computer, can't really figure out what has happened. Would be great if anyone can direct me to the right direction for solution.

2021-02-16 07_11_03-This PC.jpg


I always have three external HDD attach to my desktop computer running latest windows. Suddenly, since yesterday after turning on the computer the three drive after clicking to open getting message "is not accessible. Access is denied." Please see the picture.

2021-02-16 08_11_15-Location is not available.jpg


Things that I have done so far...

Firstly, I went to drive properties - security - Advanced - Owner ( Chance )
Then it does not take me to the next box but displaying "You do not have permission to view or edit this object's permission settings." therefore I cannot change anything.
2021-02-16 07_13_16-Advanced Security Settings for Local Disk (K_).jpg


After clicking change owner
2021-02-16 08_14_34-Advanced Security Settings for Local Disk (K_).jpg




Secondly, I also tried to change group policy, Administrative Templates - System - Removable storage access - removable disks deny Access, read, right (all three to disable)
still no changes

Thirdly, I have also updated the chipset driver

Fourthly, checked settings on Bios, all seems all right with the latest Bios firmware

It is worth mentioning that I'm getting notification every time is turn on/restart the computer ''pc need to be restarted to finish setup". But, after restart nothing happens and same notification keeps on showing.

I have checked all my HDD with a different computer, all external HDD are 100% functional.

System spec:
TR4 X399 Gigabyte Motherboard
AMD 1920x threadripper
32gb ram



regards to all :)
 
Ad

Advertisements

Joined
Feb 16, 2021
Messages
6
Reaction score
0
Are the external HDD's connected via a hub, or are they connected DIRECTLY to your computer's USB ports?
Hubs are notorious for causing problems like this, so if you ARE using a hub with all three drives on it, remove them all, and just for the purposes of experimentation at this point plug ONE external drive directly into the PC USB port - leave the hub to the side for now.
If that allows you access, the hub is the issue. I have found that more often then not, you have to connect USB HDD's directly to the PC USB ports to make them work. That has been my experience anyway.

Also, are they 2.5" ones or 3.5" ones with their own separate power-supply?
3.5's with their own power-supply SHOULD work OK via a hub, but that isn't necessarily the case either.
2.5's via a hub can be a real problem as the hub won't have the current to power all the drives unless the hub is a powered one that specifically says it is designed to work with USB HDD's etc.

You don't NORMALLY need to dig that deep into permissions and policies etc, to make a USB HDD work - they should just work without you having to give them any special treatment at the W10 level.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top