Lost "Rich Text Document" on the Menu when right clicking.


Joined
Sep 10, 2016
Messages
4
Reaction score
0
Something went wrong after Windows 10 Anniversary Update (Version:1607) was downloaded. When right clicking so I can
create a "New" document, preferably "Rich Text Document", the only one that shows up on the list is "Text Document", it
would be nice if someone can explain how I can get it back on the list (the "Menu" list).
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
2,937
Reaction score
910
Hi Happy Gill,

The context menu is controlled by ShellNew entries under the HKEY_Classes_Root in your Registry.

If you'd like to add the option to select New > Rich Text Document to you context menu then follow the following instructions to achieve this option:
  • Right-click on Start
  • Left-click on Command Prompt (Admin)
  • When the User Account Control opens click Yes
  • In the Administrator: Command Prompt window now open type or copy & paste the following command:

    Code:
    reg add "HKEY_CLASSES_ROOT\.rtf\Word.RTF.8\ShellNew" /v Filename /t reg_sz /d Document.rtf
    Press Enter key to execute

    You'll see a confirmation that action was successful.

    Type Exit then press Enter key to close the Administrator: Command Prompt window.

Now right-click on Desktop and select New - you may not see the Rich text option yet. If you don't Right-click on Desktop a second time and select New again and this time you'll see it.

If you prefer not to do all that typing I've attached a REG file you can simply download, right-click on and choose Merge to do the above automatically. After downloading, always do a quick virus scan of the downloaded file first.

Regards,

Regedit32
 

Attachments

Ad

Advertisements

Joined
Sep 10, 2016
Messages
4
Reaction score
0
Did everything you instructed me to do. Still dont see it on the sub-menu list after right clicking on the Desktop. I also tried to apply it inside of "File Explorer", no luck. I really appreciate your help.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
2,937
Reaction score
910
The System needs to update itself when you make a change to the registry.

You could try refreshing desktop, or simply restart computer for changes to take affect.

Before doing that though you could check your change took affect by:
  • Right-clicking on Start
  • Left-clicking on Command Prompt (Admin)
  • When the User Account Control opens click Yes
  • In the Administrator: Command Prompt now open type or copy & paste the following:

    Code:
    reg query "HKEY_CLASSES_ROOT\.rtf\Word.RTF.8\ShellNew"
    Press Enter key to execute

    You ought to see the following:

    Untitled.png


    Can you confirm you see this result?

    If the edit did take place and restarting computer still has no affect, then we can try a trick you used to do in Windows 7 days that may work in Windows 10 - although I've not had to do that myself as the edit I gave you worked fine on its own.
I'll wait till you respond to above first though.

Regedit32
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top