SOLVED Not sure if this goes in Drivers or Hardware- Hitachi LE23E6R9 as a screen


Joined
Sep 12, 2016
Messages
7
Reaction score
0
I'm finding that on Windows 10 I have poorer display quality on this TV than I do under Ubuntu.

According to Hitachi it should be able to run 1920X1080 at 120Hz see http://www.hitachi-america.us/products/consumer/tv/docs/tvs/alpha-roku/LE32E6R9_Specification.pdf

Windows 10 is enumerating the display as a Generic PnP Monitor limiting me to 60 hz and while I can set it to 1920X1080 windows systems it should be 1024X768

What can I do to improve the display short of replacing it?
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,521
Reaction score
1,076
Have you checked in Device Manager whether the correct or latest driver for your tv is being used?

Type Device Manager into the Cortana search field and press Enter
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,521
Reaction score
1,076
You earlier posted a PDF about your TV.

Are you able to search that site, for Drivers?

Or, does the User Manual, the PDF inferred comes with the TV provide a website to grab drivers for the TV.

Alternately, in Device Manager, if you right-click on that Generic driver and select Update, then choose to search automatically for driver ( i.e. the first option presented after selecting to Update driver ) perhaps that will find a better driver for you.
 
Joined
Sep 12, 2016
Messages
7
Reaction score
0
Yes, I found no drivers on Hitachi's website. I have tried allowing Windows Update to find a new driver but that is also not finding anything, I wish there was a program to make a .inf file for my display
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,521
Reaction score
1,076
That PDF has a support website for Roku.

I've found two pages that might help you:
  1. https://support.roku.com/en-gb/article/208754888

  2. https://support.roku.com/en-gb/article/235168467
There may be other pages on this site more relevant to your model.

In addition to that, there is an official Service Department Website, where you can fill out a form and submit to get support from a Service Technician. That site is here: https://hitachidmd.force.com/hitachiserviceusa/s/

From what I can tell from the various documents I've read, you may have installed some software on your computer, or the TV itself, that allows you to check your settings, and also update the TV software. You may find a setting there that would help.

Other than that you will need to confirm your TV cable to Computer is connected to a supported port, that can handle the input/output you are expecting from your Display.

Beyond this I am out of ideas, but someone else in our Forum may be more familiar with your type of TV and be able to give you more technical advice.

Good luck resolving this issue.

Regedit32
 
Joined
Sep 12, 2016
Messages
7
Reaction score
0
Thank you but I believe the issue is with Windows 10 seeing the TV as a generic Plug and Play monitor and not the TV itself.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,521
Reaction score
1,076
I had another thought — a couple actually.

Return to Device Manager then:
  1. Expand the Display adapters then right-click the listed item and select Update driver — Use the automatic search for this.

  2. Expand the Monitors then right-click on Generic PnP Monitor and select Update driver then select:
  • Browse my computer for driver software
  • On the next window select Let me pick from a list of available drivers on my computer
  • On the next screen, remove the check next to: Show compatible hardware
  • You should now see two scrollable fields. On the left field scroll and select Hitachi then on the right field select the appropriate option for your Monitor, then click Next button.

    Note: You may not see in the right field an item matching your monitor. If that's the case you could still consider trying the most recent listed item and see if its compatible. I've done this with an HP Monitor that was displaying as Generic PnP Monitor, and in the right field I selected the last item in the scrollable list. It seems to have worked fine so far.

    Another option is clicking the Have Disk button then browsing your computer to the directory that your software for Monitor is located at, and seeing whether or not there is a Driver folder there you can open and select a driver.
 
Joined
Sep 12, 2016
Messages
7
Reaction score
0
Thank you. Your suggestion did not resolve my problem directly but lead me on a path that did. When I went into Hitachi I didn't find anything close to what I have. Then I started browsing the Manufacturer list and under (Standard monitor types) I saw a few Digital Flat Panel options. I chose the 1920 X 1080 at 60hz and now my text is clearer.

1575482386737.png
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,521
Reaction score
1,076
That's great!

Thanks for posting what worked for you. In time that might well help another Forum user or guest browsing the site.

On a side note: Hitachi would do its users a favour if they could make navigating their website simpler — I felt like I may have skipped past something that may have been more relevant to your case.

Regards,

Regedit32
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top