SOLVED NOTEPAD opens after Windows 10 ver.1803 boots


Joined
Oct 23, 2017
Messages
12
Reaction score
1
After upgrading Windows 10 to version 1803 on May 1 I have started getting a problem - Notepad opens with desktop.ini as soon as OS finishes to boot.
The content of Notepad is empty and a message says: you don't have permission to open this file.
1. Firstly, I searched my C: drive for any created desktop.ini file(s)

I found there three files located in different folders:
a) C:\users\desktop.ini
when I click on file I can read the content in notepad
[.ShellClassInfo]LocalizedResourceName=@%SystemRoot%\system32\windows.storage.dll,-21813
(the file was created on 4/11/18)

b) C:\Users\User's Name\AppData\Roaming\MS\Windows\Start Menu\desktop.ini

I can read as well as its content in notepad
..........................................................................................................dll, -21786
( the file was create on 5/1/18 )

c) C:\Users\User's Name\AppData\Roaming\MS\Windows\Start Menu\Programs\Startup\desktop.ini

the file in notepad is empty and was created on 4/11/18

I verified this empty notepad file pops up when Windows 10 finishes to boot.
Also, I checked the security of this file that I cannot delete from the drive.
I checked my drive for any viruses and adware, it is clean.

Any help is appreciated.




 
Ad

Advertisements

Joined
Apr 22, 2017
Messages
2,640
Reaction score
302
Hi Terrier,

is it showing in Task Manager > Start-up?: :) If it is, you can disable it at least!. ;)

upload_2018-5-6_7-1-47.png
 
Ad

Advertisements

Joined
Oct 23, 2017
Messages
12
Reaction score
1
All,
I found a workable solution for the described issue by deleting this desktop.ini file from my drive.
I opened the Security tab in Property of this file. There I read that no group or users have permission to acceess
this object. So I edited allowing "Everyone" to have a permission to this object.
More detailed steps for that are:
Click on Edit in Security tab, then click Add. Under "Enter the object names" to the select box type Everyone and
click "Check Names", click OK. A new window will open up with Security tab under "Permissions for Everyone",
checkmark "Full Control" option and click Apply, OK.
So the new ownership allows to delete the described above desktop.ini file and after rebooting the computer
the notepad do not reappear more.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top