Recording Device In USB Port No Longer “Shows Up” in Windows 10 Screen


Joined
Aug 8, 2015
Messages
25
Reaction score
0
I have a small USB recording device, and when I used to plug it into a USB port on my Windows 10 PC, the drive that it represented would then be displayed on my screen automatically. For some reason, that no longer happens. If I want to see the drive of my USB recording device, I have to access “File Explorer”, and then find the drive. I can’t find anything in “Settings” that can change it back to the way it was, where the drive icon appeared automatically. Can anyone suggest any fixes?
 
Ad

Advertisements

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
12,901
Reaction score
2,172
Settings -> Devices -> AutoPlay (left column)
Is the device listed there?
I have most of my such devices set to "Open folder to view files (File Explorer)"
It's possible that if it's one of those more sophisticated digital recorders used by some attorneys and other professionals that you may have to reinstall the software package, which may even include a driver for the dock.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top