Samsung MTP USB driver

Joined
Jun 8, 2017
Messages
8
Reaction score
1
Hi.
I have just refreshed my Windows 10 64bit and cannot connect my Samsung S5 phone. I have gone into MTP on the phone and that is selected. It does not show up on my computer. I have been into device manager and uninstalled and reinstalled the drivers. I have tried Kies, SmartSwitch and also Samsung USB driver. Whatever I have tried, does not work. With every driver I have tried to install, each time it says that \"The data is invalid\". I have also tried a hardward ID search for USB\\VID_04E8&PID_6860&REV_0400&MI_01 and when installing that, the data is invalid pops up. I have also tried Microsoft MTP Porting Kit and also gaining administrative rights via command prompt. I have also done a SFC check and everything is OK. Also on my phone, I am prompted with a message that says the connected device is unable to access data on this device.
Of which then tells me to reconnect the usb cable, of which I have done many times and also tried a different cable. It also says about installing smart switch.

My USB Settings' on my phone are, MTP +ADB.and my phone has the latest updates.

My phone was working on this pc a few days ago.

I'd welcome any replies.
OS:Microsoft Windows 10 Pro/64bits
Dell Inspiron 5558


Thanks
 
A

Advertising

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top