Since update, Setup forces formerly unneeded Configuration Process on Office 2007


Joined
Nov 15, 2017
Messages
1
Reaction score
0
Using Office Home & Student on several Win10 computers.

Since November 1st update, any WORD or Excel file, whether blank or existing, is delayed from opening with this message: “Please wait while Setup prepares the necessary files” ... followed by “Configuring Process: Office Home & Student 2007”. This never-before-wait-time is very frustrating and inefficient.

Should I reload the software? (currently cruising, so no disk access until December.)

Should I, or can I, roll back the Update?

Is there any corrective action possible?
 
Ad

Advertisements

Joined
Nov 19, 2013
Messages
4,558
Reaction score
887
It could be the configuration of the updates. Have a look in the advanced options and uncheck this item, if you feel you are satisfied with the way Office is performing.

Capture.PNG
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,196
Reaction score
998
Hi nosredneh,

Welcome to the Forum.


There are a number of things that can trigger the messages you are seeing when attempting to open Office files.

Below are three of the more common reasons for this message to appear and how to resolve it.


The first thing you ought to try is to use Microsoft Office's built in repair tool:
  • Press your windows key + S to give focus to your search field
  • In the search field type control then press Enter key to open your Control Panel
  • With your Control Panel open:
    • If you are viewing the window by category then click Programs then Programs and Features
    • Or, if you are viewing the Control Panel window by small or large icons click on Programs and Features
  • Scroll down the list of installed applications and right-click on your Microsoft Office and select Change
  • Having selected Change you ought to get two choices:
    1. Quick Repair, or
    2. Online Repair
It's up to your preferences, but usually quick repair will do the job, but it's fine if you would rather to an online repair too.


If you have installed a 32-bit version of Microsoft Office Home & Student but your computer's architecture is 64-bit then this has been known to trigger an issue that results in an Information message that reads something like Please wait while Microsoft configures 64-bit Components . . .

If you are getting such a message then you can resolve this by doing the following:
  • First, you need to close any instances of your Office application. To be certain, all instances are closed, press Ctrl + Alt + Delete keys together then select Task Manager and check the list of running Apps and also Background Processes to make sure no Office instances are still running. If you see a running one, right-click it and choose End task. When done close Task Manager.
  • Next, press Windows key + S to give focus to the Search field
  • In the search field type windows features then press Enter key
  • You will now see the Windows Features dialog that has a sub-heading Turn Windows features on or off. In this window, scroll down and locate Windows Search. If the box next to Windows Search is not checked then Check the Box then click OK
  • Close any other open applications, and restart your computer for change to take affect.

Another possibility if you have added a third-party Extension to your program, and it is this causing the issue. If you have added a third-party Extension then try running Office in Safe Mode. To do that:
  • Press your windows key + S to give focus to your search field
  • In the search field type the office program you wish to open (e.g. WORD, EXCEL, etc)
  • In the search results locate the program you searched for, and while holding your CTRL key down with your mouse open the program. This will open the Office program without access to extensions (i.e. Safe mode for Office). If the program runs well with no annoying messages in Safe mode, then you will want to disable and/or remove any third party extensions ( one at a time if you have more than one, to figure out which one is triggering the issue. When you know which one remove it permanently ).
I have not used the edition of Office you are having troubles with, but you ought to be able to get to the Add-ins when your program (e.g. WORD) is open by clicking File > Options > Add-ins.

In the window that opens at bottom use the drop box next to Manage to select COM add-ins, then in the box above you can disable / remove add-ins you feel may be causing the trouble.​


Finally, if the issue is simply a case of Office attempting to re-register itself each time you open one of its programs you can prevent this setup/configuration issue by adding a NoReReg DWORD value to your Registry:

As you are using a 2007 version you would do the following:
  • Press your windows key + s to give focus to your search field
  • In the search field type command
  • In the search results locate and right-click on Command Prompt and select Run as administrator
  • When the User Account Control prompts you click Yes
  • In the Administrator: Command Prompt console type or copy & paste the following:
Code:
REG ADD HKCU\Software\Microsoft\Office\12.0\Word\Options /v NoReReg /t REG_DWORD /d 1 /f
Press Enter key to execute

Sample image

reg.png


Type exit then press Enter key to close the console​
  • Close any other open applications then restart computer

Regards,

Regedit32
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top