SSD external USB3 drive keeps shutting down, power management is disabled


Joined
Mar 9, 2017
Messages
8
Reaction score
3
An external Toshiba 500gB SSD drive fitted to my recently rebuilt machine Win10 X64 keeps randomly shutting itself down. Model nmbr DTB305 purchased December 2017

I have disabled fast start and also sleep mode. It is connected to the main USB3 port on the IO plate.

Removing and replugging the usb connection wakes the drive up, no other action will.

Power management has been disabled on the root USB hub and anything else related to the drive.

I also tried updating USB drivers and for the SSD, they were all up to date anyway.

Sometimes it will shut down after an hour, sometimes it stays on much longer.

The only use for the drive is critical file backup using Syncback Pro with real-time fast saves enabled, and a scheduled weekly (Sunday)system image via WIN10 utility.

A Google search does not show a solution that I have not tried.

Help please, regards Jonathan
 
Ad

Advertisements

Joined
Mar 9, 2017
Messages
8
Reaction score
3
Maybe use a program like this one to keep the drive alive. I don't use it. Just a suggestion for you.

https://www.ghacks.net/2009/03/03/prevent-external-hard-drives-from-entering-sleep-mode/
Thanks Ram1220, for the moment I have disabled sleep mode (extended it to 6 hours before sleep) which has stopped the problem, although preferably I would want revert to allow sleep at 45 mins.

I looked at NoSleep utility, and its HD version. It was last maintained in 2009. Also found an alternative called KeepAliveHD which was last updated 2017. So, I am trying that.

I will note back after a few days trialling to say how it works on 64bit Win10.

Regards Jonathan
 
Joined
Mar 9, 2017
Messages
8
Reaction score
3
Check your power options, Advance option USB settings
Thanks for your reply Clintlgm.

As noted in my first post, disabling power management for the root usb hubs and anything else related to the drive was a solution I had tried which was ineffective.

But, thanks for you thoughts to help.

Regards Jonathan
 

Trouble

Noob Whisperer
Moderator
Joined
Nov 19, 2013
Messages
12,793
Reaction score
2,123
Disabling "Allow the computer to turn of this device to save power" under the power management tab in device manager is a good first try, but...
You may also want to have a look at your advanced power management settings with respect to
USB settings
AND
PCI Express -> Link State Power Management
Make sure they are both off / disabled

Capture.PNG
 
Ad

Advertisements

Joined
Mar 9, 2017
Messages
8
Reaction score
3
Disabling "Allow the computer to turn of this device to save power" under the power management tab in device manager is a good first try, but...
You may also want to have a look at your advanced power management settings with respect to
USB settings
AND
PCI Express -> Link State Power Management
Make sure they are both off / disabled

View attachment 8027
Thank you Trouble, I have applied both those settings.

I will trial it a few days and note back if it resolves.

Regards Jonathan
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top