USB doesn't recognize camera device


Joined
Dec 26, 2015
Messages
56
Reaction score
0
I have had same problem with my Canon cameras, sounds similar so I do comment.
May not be at all what is causing your problem.
First I tried to download and reinstall drivers (Canon Camera Window).
Did not help. Got new camera / USB cable.
Switching cables has worked for a while until it too stopped working.
The problem I discovered was that outer pin in the socket was pushed deeper into socket.
(Must have tried to insert the cable in crooked and pushed the pin in)
New cable had a tighter end connection so it worked.
Until it quit altogether and the idea that I should try another USB port not ocured to me before.
Switching USB port worked - conclusion - my original camera port at fault.
The pin was pushed so far back now that it has broken off the printed circuit board connection.
That is how this problem was finally diagnosed as pure mechanical one - nothing to do with drivers or cables.
Have a good look at your USB socket with a magnifier to see if all pins are straight and same length.
 
Joined
Sep 26, 2017
Messages
1,513
Reaction score
250
For such times as one of my clients will have a similar issue with their camera I keep a Targus High Speed SC/SDHC/MMC/Micro SD/T-F pocketable USB device that accepts those camera memory cards in my tool kit. It's about $10USD at Wal*Mart. It saves a lot of headaches in retrieving photos even from the Micro SD cards in cellphones.
 
  • Like
Reactions: Bif
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top