USB MICE UNUSABLE / Error CODE 10 Device Manager (PS/2 Bug)


Joined
Jan 29, 2017
Messages
2
Reaction score
1
Hello everyone!

I'm encountering a really annoying and unpredictable problem: for a reason I ignore, my mice (Mad Catz RAT 7) isn't recognized by Windows and has just stop working.

When I plug it in, the mice's leds lights up 10sec then suddently light off, and the cursor/clics don't move/operate at all.
I've tested my RAT 7 on a different computer (Dell XPS 13 L322X, running Windows 10), it works. Then, I plugged a different mice on my computer (Dell XPS 15 9560, running Windows 10), this one didn't work and wasn't recognized too.
Moreover, all my USB ports works correctly (tested with other stuff like USB Drive, External Drive, External SoundCard, Windows Phone...).

So, the problem is on the software side.

There what my device manager shows:
FileDownloadHandler.ashx


We can see that the RAT 7 is still recognized as the driver is still installed on my computer.
Since, I've tried to uninstall/reinstall this driver, but it didn't change anything to my problem.

On the picture, we can see a "PS/2 compatible mice" that can't actually rune (error code 10):
FileDownloadHandler.ashx


I've tried to uninstall this device from device manager, and plugging again my RAT 7, without success.
I've tried to uninstall everything under "USB bus" including the host one and restart, without success too.


I've tried this tricks too:

_built-in Windows problem/issue solver in administrator mode + Microsoft Fix it tools
_attempt to delete registry keys "Upperfilter"/"Lowerfilter" in LOCAL MACHINE, but those keys appeared to basicaly not exist on my system...
_system restore before the bug appeared
_attempt to repair from a Windows 10 live USB boot

...WITHOUT SUCCESS :'(

I'm asking you now becaus I'm kinda running out of options actually, and I strictly don't want to reinstall/format my system as I've been doing it 2 weeks ago and been reinstalling my whole CAD/DAW software suites...

I'll send you every kind of logs files that could be useful! :)


There is my setup:


Windows 10 x64, 1607 (14393.693)

Dell XPS 15 9560:

Intel i7 6700HQ 2,6 / 3,6 GHz
16Gb ram
GeForce GTX 960M 2Gb DDR5 / Intel Iris 530
SSD Samsung 512Gb
 
Ad

Advertisements

Joined
Jan 29, 2017
Messages
2
Reaction score
1
I finally found the ULTIMATE FIX for my problem, thanks to @PatriciaGuenot from french Microsoft Community!

There is it:

  • disconnect every useless USB devices
  • uninstall completly every antivirus on your system
  • full disk cleanup from disk cleanup utilitary
  • delete C:\$WINDOWS.~BT. if existing
  • Download Windows 10 ISO here: https://www.microsoft.com/fr-fr/software-download/windows10
  • Right-Clic on ISO, "Mount"
  • Inside mounted volume, double clic on "setup" and Windows Upgrade/Repair
Now let the magic happen...

Link to original post (in french): https://answers.microsoft.com/fr-fr/windows/forum/windows_10-hardware/souris-usb-inutilisable-erreur-code-10/f8ce3ed9-df33-4e89-a780-b88a1cdc8e84?tm=1485659397763&rtAction=1485689591580&auth=1
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top