Win 10 connecting to internet in safe mode with networking over WIFI


Joined
Feb 21, 2016
Messages
19
Reaction score
2
When trying to connect to internet in safe mode with networking in win 10 over WIFI, the WIFI driver does not load. I can connect using Ethernet. Is there a solution for this.
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,133
Hi ozzie matics,

When I want to use WiFi in Safe mode with Windows 10 Home build 14393.953 what I do is the following:
  • From normal log in I press Windows key and R key to open the Run dialog
  • Type msconfg then click OK
  • Select the Boot tab and Check the Safe boot & Networking boxes then apply and Restart
  • When the computer reaches the Lock Screen I click on the Network icon and select my wireless network, then enter the password.
  • Then I sign into the Safe mode desktop

That ought to work but if not an alternate method would be to sign in to Safe mode, then open an Administrator Command Prompt and type the following:


Code:
Netsh wlan connect name="SSID"


Note: You must keep the speech marks and replace the SSID with your Wireless Security name


Press Enter key to execute when you have the correct information typed in.


You could create a tiny batch file for this by opening a Notepad and entering these three lines:


Code:
powershell.exe -Command "Start-Process cmd \"/k cd /d %cd%\" -Verb RunAs"
Netsh wlan connect name="SSID"
Pause

Then select File > Save as and name it wlan.bat and choose all files before saving. Save on your Desktop for easy access when you log into Safe mode, and when in Safe mode, right-click and run as Administrator.

Notes:
  1. Again keep the speech marks and replace the SSID with your wireless security name.
  2. When executed a blank Command console may appear, but if you close that you ought to see another beneath it. Sorry I don't have time just now to write a better batch to avoid that.
  3. The Network icon in system tray may still appear to be unavailable, but if batch says it was successful, then you ought to be connected.

Here's hoping the first suggestion works for you as its the simplest way to get there. This was introduced with the Anniversary update by Microsoft to resolve this known issue for some users.


Regards,

Regedit32
 
Joined
Feb 21, 2016
Messages
19
Reaction score
2
Hi ozzie matics,

When I want to use WiFi in Safe mode with Windows 10 Home build 14393.953 what I do is the following:
  • From normal log in I press Windows key and R key to open the Run dialog
  • Type msconfg then click OK
  • Select the Boot tab and Check the Safe boot & Networking boxes then apply and Restart
  • When the computer reaches the Lock Screen I click on the Network icon and select my wireless network, then enter the password.
  • Then I sign into the Safe mode desktop

That ought to work but if not an alternate method would be to sign in to Safe mode, then open an Administrator Command Prompt and type the following:


Code:
Netsh wlan connect name="SSID"


Note: You must keep the speech marks and replace the SSID with your Wireless Security name


Press Enter key to execute when you have the correct information typed in.


You could create a tiny batch file for this by opening a Notepad and entering these three lines:


Code:
powershell.exe -Command "Start-Process cmd \"/k cd /d %cd%\" -Verb RunAs"
Netsh wlan connect name="SSID"
Pause

Then select File > Save as and name it wlan.bat and choose all files before saving. Save on your Desktop for easy access when you log into Safe mode, and when in Safe mode, right-click and run as Administrator.

Notes:
  1. Again keep the speech marks and replace the SSID with your wireless security name.
  2. When executed a blank Command console may appear, but if you close that you ought to see another beneath it. Sorry I don't have time just now to write a better batch to avoid that.
  3. The Network icon in system tray may still appear to be unavailable, but if batch says it was successful, then you ought to be connected.

Here's hoping the first suggestion works for you as its the simplest way to get there. This was introduced with the Anniversary update by Microsoft to resolve this known issue for some users.


Regards,

Regedit32
 
Joined
Feb 21, 2016
Messages
19
Reaction score
2
Thanks for your reply Regedit32. I tried what you suggested but still cannot connect to my WIFI in safe mode. When I look at the device manager there is a yellow triangle over the wireless lan card. When I look at the properties of the card it says windows cannot initialize the device driver for this hardware.
 

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,620
Reaction score
1,133
Hi ossie matics,

Is your Wireless Device showing this error in Device Manager when you are booted in normal mode, or only when in Safe mode?

If its in the Normal mode, then unplug it if an external device, and remove the driver for it, then reinstall it.

If it's an internal card, then attempt to uninstall and reinstall the driver anyway.

Check too if there is a more recent driver for that too as it may be more compatible with a Windows 10 OS.


If the device is external and is connect in any way via a USB port then you may need to uninstall its related drivers on the USB Serial Ports in Device Manager too, before attempting to reinstall the device.


Others in the Forum may have some views to share.


In the meanwhile if you can respond and let us know answers to questions above, and whether you tried anything suggested above to resolve the issue.


Regards,

Regedit32
 
Joined
Feb 21, 2016
Messages
19
Reaction score
2
I tried the things you suggested and still get the same results. My wifi adapter is external and I usb3 connection. Once in safe mode and I check the adapter in device manager safe mode I get
Code 37: Windows cannot initialize the device driver for this hardware
In normal mode everything works fine. My drivers are current with the proper signatures. I don't know if it matters but I use a VPN.
 
Ad

Advertisements

Joined
Feb 21, 2016
Messages
19
Reaction score
2
Hi ozzie matics,

When I want to use WiFi in Safe mode with Windows 10 Home build 14393.953 what I do is the following:
  • From normal log in I press Windows key and R key to open the Run dialog
  • Type msconfg then click OK
  • Select the Boot tab and Check the Safe boot & Networking boxes then apply and Restart
  • When the computer reaches the Lock Screen I click on the Network icon and select my wireless network, then enter the password.
  • Then I sign into the Safe mode desktop

That ought to work but if not an alternate method would be to sign in to Safe mode, then open an Administrator Command Prompt and type the following:


Code:
Netsh wlan connect name="SSID"


Note: You must keep the speech marks and replace the SSID with your Wireless Security name


Press Enter key to execute when you have the correct information typed in.


You could create a tiny batch file for this by opening a Notepad and entering these three lines:


Code:
powershell.exe -Command "Start-Process cmd \"/k cd /d %cd%\" -Verb RunAs"
Netsh wlan connect name="SSID"
Pause

Then select File > Save as and name it wlan.bat and choose all files before saving. Save on your Desktop for easy access when you log into Safe mode, and when in Safe mode, right-click and run as Administrator.

Notes:
  1. Again keep the speech marks and replace the SSID with your wireless security name.
  2. When executed a blank Command console may appear, but if you close that you ought to see another beneath it. Sorry I don't have time just now to write a better batch to avoid that.
  3. The Network icon in system tray may still appear to be unavailable, but if batch says it was successful, then you ought to be connected.

Here's hoping the first suggestion works for you as its the simplest way to get there. This was introduced with the Anniversary update by Microsoft to resolve this known issue for some users.


Regards,

Regedit32
 
Joined
Feb 21, 2016
Messages
19
Reaction score
2
I've tried every suggestion but still can't access my wifi in safe mode. I connect my desktop over wifi and not over LAN connection. The end results are that my wifi driver in the device manager is never initialized. I'm using Win 10 Pro with latest updates. Win 10 Ver 1803 build 17134.48. Can this safe mode connection even be done over Wifi.
 
Joined
Feb 21, 2016
Messages
19
Reaction score
2
I finally solved my problem by connecting a spare usb wifi adapter. My primary usb adapter that I use to connect to the Internet would never initialize in safe mode. I did not uninstall it I simple plugged in a spare usb adapter and it connected fine.
 
Joined
Sep 29, 2018
Messages
1
Reaction score
0
I will realy like to open this issue again....I'm having the exact same error as ozzie...can someone help? NOTE: I do not have an USB wifi card :-(
 
Joined
Mar 3, 2021
Messages
2
Reaction score
0
How can I connect to my wifi in command line it’s saying my “network interface card unavailable”
 
Ad

Advertisements

Rud

Joined
Apr 26, 2021
Messages
1
Reaction score
0
Hi ozzie matics,

When I want to use WiFi in Safe mode with Windows 10 Home build 14393.953 what I do is the following:
  • From normal log in I press Windows key and R key to open the Run dialog
  • Type msconfg then click OK
  • Select the Boot tab and Check the Safe boot & Networking boxes then apply and Restart
  • When the computer reaches the Lock Screen I click on the Network icon and select my wireless network, then enter the password.
  • Then I sign into the Safe mode desktop

That ought to work but if not an alternate method would be to sign in to Safe mode, then open an Administrator Command Prompt and type the following:


Code:
Netsh wlan connect name="SSID"


Note: You must keep the speech marks and replace the SSID with your Wireless Security name


Press Enter key to execute when you have the correct information typed in.


You could create a tiny batch file for this by opening a Notepad and entering these three lines:


Code:
powershell.exe -Command "Start-Process cmd \"/k cd /d %cd%\" -Verb RunAs"
Netsh wlan connect name="SSID"
Pause

Then select File > Save as and name it wlan.bat and choose all files before saving. Save on your Desktop for easy access when you log into Safe mode, and when in Safe mode, right-click and run as Administrator.

Notes:
  1. Again keep the speech marks and replace the SSID with your wireless security name.
  2. When executed a blank Command console may appear, but if you close that you ought to see another beneath it. Sorry I don't have time just now to write a better batch to avoid that.
  3. The Network icon in system tray may still appear to be unavailable, but if batch says it was successful, then you ought to be connected.

Here's hoping the first suggestion works for you as its the simplest way to get there. This was introduced with the Anniversary update by Microsoft to resolve this known issue for some users.


Regards,

Regedit32
Hi tried your method but still I can't connect to internet it says There is no wireless interface on the computer.please help
 
Joined
Sep 26, 2017
Messages
2,714
Reaction score
527
Two things can prevent Wi-Fi in Windows Safe Mode, one is that Safe Mode can get access through the Ethernet connection to the Router with basic support but do not load Wireless Adapter drivers. The other could be a hardware issue in that with a Notebook the Wireless has been turned off, could be a switch on the case or the Fn plus another key that toggles Wireless Off or On, a physical action outside the Operating System.
 
Ad

Advertisements

Joined
Jul 30, 2021
Messages
1
Reaction score
0
I am having the same problem. My wifi adapter is turned off in Safe mode. One of the required services is RCP and it can't be turned on in Safe mode. I will try the above recommendations and see. I have an external USB adapter but haven't tried it yet.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top