SOLVED Windows 10 Anti-Virus "Managed by Administrator" Fix


Joined
Jun 13, 2019
Messages
5
Reaction score
0
Not sure if this was from a virus or what but I had malware bytes and spybot installed. I ran malware bytes and cleared out some infections and uninstalled wanting to move to defender strickley. I go into the Defender page and the Security page loads blank, when I go into the anti-protection every option has "managed by administrator" on it, and the option to turn it on is greyed out. I have tired logging into the admin account and it tells me the same thing. At this point I am trying to figure out what to do. I tired deleting the Defender keys and rebooting and that didnt do anything. I am at a loss how to recover this.

Was hoping someone could give me some helpful hints, as I really do not want to have to reformat to recover this. Why does windows have to be so broken sometimes?

Cheers
 
Ad

Advertisements

Regedit32

Moderator
Joined
Mar 4, 2016
Messages
3,052
Reaction score
967
Hi Onelove,

It's possible your previous security apps edited the Registry to disable Windows Defender, or at some time you may have done this yourself using the Group Policy editor built into Windows 10 Professional editions.

Either way you may be able to resolve this by manually editing the Registry.

  1. In your search bar type reg then from the populated results list, right-click on Registry Editor and select Run as administrator
  2. If prompted by the UAC click Yes
  3. On the left pane of the Registry Editor dialog expand the HKEY_LOCAL_MACHINE hive
  4. Next expand the Software hive
  5. Next expand the Policies hive
  6. Next expand the Microsoft hive
  7. Now left-click on the Windows Defender hive to highlight it so you can view its content inside the right pane
  8. In the right pane do you see a value named DisableAntiSpyware with a data value set to 1? If you do then you can do either of the following to resolve your issue:
  • Right-click on DisableAntiSpyware and select Delete, or if you prefer to keep this then:
  • Right-click on DisableAntiSpyware and select Modify then change the data value from 1 to 0 and apply the change
When done, simple close the Registry Editor and reboot your computer for changes to take affect. You ought to then be able to sign-in to Windows and via the Settings app adjust your Windows Defender settings to your satisfaction.

Regards,

Regedit32
 
Last edited:
  • Like
Reactions: Ian
Ad

Advertisements

Joined
Jun 13, 2019
Messages
5
Reaction score
0
Thanks for the replay, I had already tired that, I just reinstalled OS, can we close this.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top